2.2.0 Windows 10 GUI Too big

Hey mixxxppl !! I try to use the 2.2.0 release on my freshly installed laptop (intel I7) and running Windows 10. But the GUI is TOO BIG :astonished: :astonished: :open_mouth: it is impossible to resize de view. I know this a QT issue but didn’t see anything for Windows OS.
Do you have a trick for that ?
thxalot!!
Jam

This is explained on the wiki, but I see it mentions a solution for Linux, not for Windows. I will correct that.

Meanwhile, you could try opening a command prompt ( type cmd on the search box in the taskbar ) and there, type:

SET QT_AUTO_SCREEN_SCALE_FACTOR=0
"c:\Program Files\Mixxx\mixxx.exe"

(Assuming that you installed Mixxx on c:\Program Files\Mixxx)

Mixxx 2.3 will work a bit better there.

I use Mixxx on Ubuntu Linux, but my backup laptop is on Windows.
I have the same problem on Windows 7. Impossible to use Mixxx in this case

I found this is a critical bug because Windows stay the major OS used today.

thanks let’s try, and i’m back. :wink:

yeeeeeaaaaass ! looks great !! :smiley: thxalot !

The Command file ( bat or cmd) need to be lauvhed as administrator to work !! :wink:

We have a bug for it:
bugs.launchpad.net/mixxx/+bug/1793954

Maybe one finds time to hack around this batch file solution.

I tried the fix:

SET QT_AUTO_SCREEN_SCALE_FACTOR=0
“c:\Program Files\Mixxx\mixxx.exe”

It didn’t work for me. Perhaps I’m inputing it wrong into Powershell (administration)(?). I’m copying and pasting as it was written, into Powershell (admin).

Any thoughts?

Hello nPrevail.

The problem in using powershell is that the “set” command in there is not the same than the “set” command in command prompt.

You could try this:

$ENV:QT_AUTO_SCREEN_SCALE_FACTOR=0
"c:\Program Files\Mixxx\mixxx.exe"

JosepMa’s solution worked. You can try different scalling factors to suit your needs. Here is the code for my batch file to launch Mixxx with this setting every time. Use Notepad and save it as a .cmd file on your desktop.

@echo off
SET QT_AUTO_SCREEN_SCALE_FACTOR=0
START c:“Program Files”\Mixxx\mixxx.exe
exit