Audio crackling in MIXXX 2.2.4 on OSX 10.11

Hi there.

I running MIXXX 2.2.4 on a

MacBookPro5,3
OSX 10.11.4 (El Capitan)
2,8 GHz Intel Core 2 Duo processor
NVIDIA GeForce 9600M GT 512 MB
8Gb RAM

I got crackles when running MIXXX.

I was able to temporarily solve the problem with the advice from the wiki:

“Raise the priority of Mixxx. While Mixxx is running, open Terminal and run sudo renice -20 pidof mixxx (your user must be in /etc/sudoers).” (Adjusting Audio Latency · mixxxdj/mixxx Wiki · GitHub)

But every time i restart MIXXX, the crackling occurs again.

Are there any suggestions for a permanent solution to this problem?

thank you

What is the size of your audio buffer? Have you tried raising it?

I’m using as interface the NI Audio 4 DJ with a buffer of 23.2 ms on 44.1. the result is a latency of 52.24 ms and a “Pufferunterlaufzaehler”(sry don’t know the english term for that) of a constant 1.
But I also tried other, higher values wich all resulted in the same crackling.

I just tested it again to verify this one more time and i got no crackling with a buffer of 92.9 ms, which resultes in such extreme latency that you can’t use that in a professional set. But when I then, step by step, lowered the buffer I ain’t got crackles till even a buffer of 1.45 ms with just 14 “Pufferunterlaufzaehler”.
With this settings i played now a ca. 45 min set. The graphic went insane, even in the preferences i got glitches and almost no possibility to change values or browse tracks because of delayed reactions, but still no crackles.

Like it looks now it won’t be possible to get the graphic updating proper on this OSX (see my other post Graphic of MIXXX 2.2.4 on OSX 10.11 stutters - #4 by Be0) Perhaps there is a highly improbable possibility of an Qt update that supports lower OSX’s, but i don think so.

if anyone know a way to got the NI interface run proper on linux, i would try now to install a smal mate distribution on this laptop and maybe get MIXXX run with my hardware on this way.

No, there is zero chance of this.

The NI Audio 4 DJ does work with Linux.

Slightly OT: I had this old deprecated interface by NI and used it with mixxx for a while and it worked. I got rid because a two soundcard setup was error prone and opted to give up on vinyl control for a while.

What sticks out is that you are using a very old macOS version. If you need to stay on that version or cannot update to a later version of macOS, you would at least want to make sure you are on the latest version of El Capitan offered by Apple, which is 10.11.6 and the supplement updates after that. Also make sure you have the latest firmware for the Audio 4DJ , iirc there was at least one firmware update by NI.

For the graphics issues: this will not be fixed, the current minimum version supported by mixxx is macOS 10.12.

As you have not been receiving security updates for a long time now, switching to Linux is probably the best idea if you want to keep that old computer in business, although I tired that a few times and had mixed results. Good luck.

1 Like

I don’t know if you’re having the same problem I am (I’m running Windows 10), but here’s what works for me .
Just before you start DJing, go to Preferences, Input, Microphone and pull down the selection … select “NONE”. Hit Apply at the bottom of the page. Then, go back to Microphone , pull down and select your microphone and hit APPLY and OK. For me, the crackling stops .
Note: The crackling I get is only when I talk so this might not apply to your situation.

Have you tried some other filter settings for the vizualisation of the Track display?
You can change the type of analyzation too, that has solved my Problems with it.