Broadcast Using External Mixer

Using Mixxx 2.2.4, trying to broadcast live from an external mixer (Presonus Studiolive AR12c). When changing the sound hardware > Input > Record/Broadcast setting to the external mixer but then the broadcast mutes and no sound from the mixer broadcast. Is there a step missing, or a bug with Mixxx.

https://mixxx.org/news/2020-06-11-Mixxx-2-2-4-released/

  • Fix broadcasting via broadcast/recording input lp:1876222 #2743

If you still have the problem with 2.2.4, it might be yet another bug, or a misconfiguration.

Could you verify if you get audio when connecting the output of the mixer into a mixxx aux input instead of the record/broadcast input? This is in order to discard that the problem is elsewhere.

Also, a screenshot of your audio preferences in Mixxx could help ( you can paste images directly into the post).

Audio did not go through when connecting the output of the mixer to the mixxx aux input.

Also please find the screenshot of the audio preferences in Mixxx.

Thanks for your assistance.

Ok, I see you are on Mac OS and that you have a very low latency.

Please, try setting the latency to 10ms or even 20ms and try it again to discard that the problem is related to that.
(Right here on Windows 10 with the integrated soundcard, depending on the API selected, I get no sound if using it under 20ms).

Also, about the test with Aux, you need to activate it from Mixxx so that it outputs to the master (this image is from Mixxx 2.3, but I believe it was quite similar in 2.2):
image

Thanks for the feedback. I updated to the Mixxx 2.3 version. I also changed the latency, testing it at 20ms and 30ms, but still didn’t hear any audio going through. I took another screenshot of the settings and the Aux. Please let us know if there is anything else we can test or do.

The “Play” in the Aux 1 section (in the skin) isn’t activated.

When I mentioned the delay, I meant the “Audio Buffer”, not the master/headphone/booth delays. Please leave these at 0 and try again to increase the Audio buffer to 20ms.

After changing the audio buffer to 20 ms and higher trying different ranges, I am still not able to have audio going through Mixxx. I see in your screenshot when “Play” is activated your audio is seen going through with the green bar next to the knob. In all our attempts I don’t see the green bar going up indicating the sound going through. Please advise. Thanks for the feedback.

Then, it seems that Mixxx isn’t able to open your device.

Have you tried recording the audio with another application?
If you don’t have any, you could try with Audacity, which is a free, opensource audio editor and should be easy enough to use for testing this.

If Audacity (or any other application) can record without issues, then please, try to record with Mixxx, then close the application and then attack the log file to this thread
You can follow these instructions to find the log file: https://github.com/mixxxdj/mixxx/wiki/Finding-the-mixxx.log-file

We tried recording. Please find the log attached. Let us know if there is anything you can find that can help us.
mixxx.log.zip (657.6 KB)

Is this the log you needed or is it something else? Any input would be very appreciated.

From the point of view of Mixxx, it seems to be working.
The only strange thing that I see is that when you use both, the input and output, the output has a latency of 0ms.
I’m not sure if this means that it isn’t working (even if it doesn’t report an error).

Debug [Main]: SoundManager::setupDevices()
Debug [Main]: SoundDevicePortAudio::open() "SoundDeviceId(Built-in Output, 1)"
Debug [Main]: framesPerBuffer: 64
Debug [Main]: Requested sample rate:  48000 Hz, latency: 1.33333 ms
Debug [Main]: Output channels: 2 | Input channels: 0
Debug [Main]: Opening stream with id 1
Debug [Main]: Opened PortAudio stream successfully... starting
Debug [Main]: PortAudio: Started stream successfully
Debug [Main]:    Actual sample rate:  48000 Hz, latency: 14.6042 ms
Debug [Main]: SoundDevicePortAudio::open() "SoundDeviceId(StudioLive AR12c, 2)"
Debug [Main]: framesPerBuffer: 64
Debug [Main]: Requested sample rate:  48000 Hz, latency: 1.33333 ms
Debug [Main]: Output channels: 0 | Input channels: 2
Debug [Main]: Opening stream with id 2
Debug []: SSE: Denormals to zero mode already enabled
Debug []: SSE: Flush to zero mode already enabled
Debug []: Denormals to zero mode is working
Debug [Main]: Opened PortAudio stream successfully... starting
Debug [Main]: PortAudio: Started stream successfully
Debug [Main]:    Actual sample rate:  48000 Hz, latency: 0 ms


Debug [Main]: SoundManager::setupDevices()
Debug [Main]: SoundDevicePortAudio::open() "SoundDeviceId(StudioLive AR12c, 2)"
Debug [Main]: framesPerBuffer: 64
Debug [Main]: Requested sample rate:  48000 Hz, latency: 1.33333 ms
Debug [Main]: Output channels: 2 | Input channels: 2
Debug [Main]: Opening stream with id 2
Debug [Main]: Opened PortAudio stream successfully... starting
Debug [Main]: PortAudio: Started stream successfully
Debug [Main]:    Actual sample rate:  48000 Hz, latency: 5.52083 ms