Can you disable the in ear monitor

So when you talk you always have that in ear echo is there a way to disable that? It throws me off trying to talk when i hear my voice reverberating in my ears like an announcer at a baseball game, it’s become very annoying.

Yes you can set the microphone monitor mode to direct monitoring in the Sound Hardware preferences to disable software monitoring.
https://manual.mixxx.org/2.3/en/chapters/microphones.html