Can't get both voice and music to record at the same time

I keep trying to set up to record shows. But I can’t seem to get both the music I’m playing and my voice to record in the same recording. I have played around with settings and looked up every tutorial I can find. But I am stuck being able to record my voice only with the music not recording. Or the music recording but not the voice. I’m pretty sure I’m doing something wrong but just can’t figure it out.

Does the music volume go down when you press any Talk button?
If yes, mic ducking is probably misconfigured. Find the microphone ducking section in the GUI and center the Strength knob.
https://manual.mixxx.org/2.3/en/chapters/microphones.html#microphone-ducking

Nope. No drop in music volume at all. And it doesn’t register anywhere either.

I have no idea what you are talking about.
Please explain your setup, what you are doing, what you expect to happen, and what happens instead.

I think that i’m having the same issue.
Let me explain please. so…
I’m trying to record a radio show, but i can not manage to hear my voice in the recorded file but only the music.
Output Settings. (This means headphones)


Input Settings. (this means headphones microphone)

Input Settings. (this means headphones microphone)

Of course when i’m talking during the show i press the “talk” button as you can see…
Στιγμιότυπο 2021-10-11, 1.32.26 πμ

But in the recording is only music, that reduce volume at the time i press “talk” but not my voice is recorded. Any ideas how i can solve this? I use a macbook air m1.

Thanks for the detailed description.

Do you hear yourself on the recording if you change the mic monitor mode to “Master only” or “Master and Booth”?
After that, is the correct monitor mode restored if you restart Mixxx?
(just trying to figure out if the issue is maybe with the preferences or audio processing)

You might try setting ‘Headphones’ to your headphones, and ‘Master’ to ‘Internal speakers’ and turn the speaker volume down.