Complete Mapping for MixTrack Pro II is ready !

Hi everyone,

Merry Xmas & Happy New Year 2015! I have a gift for you.

I’m new guy here. After I purchased my MixTrack Pro II, I desperately seek its mapping. There are several mappings around. However I found none of them are really completed. Most of them are just workaround based from old MixTrack Pro mappings. Finally I completed their works (big kudos for them).

This mappings aim to make your Mixtrack Pro II work as close to the manual. The only modification is the FX buttons since Mixxx v.1.11 only supports one FX. Please read manual documentation (pdf) in the zip file.

The enhancements:

  1. Hold Shift + Play will activate Brake effect
  2. Hold Shift + Stutter will activate spinback effect

SPECIAL LED INDICATOR
• Top row of pads flash when channel clipping occurs (too loud).
• Cue Button blink at Beat time in the ultimate 30 seconds of song.
• Stutter Button blink at each Beat of the grid.

Known Issue:

  • Cue Point Led is not off when you shutdown. This is simply because I don’t know how to get to know the address, if someone knows please tell me.
  • ToggleSelectedSidebarItem control is not working (this is known bug in Mixxx reported somewhere else)
  • After activating brake, Play button is not working. It plays normal after you re-touch the platter. is this normal behavior ?

Best regards,

Armen Rizal
Mixxx-Mapping-Numark-MixTrack-Pro-II.zip (271 KB)

1 Like

Hi there,

I’ve completed the missing LED address. Please update using the script file attached here.

Regards,

Armen
Numark-Mixtrack-Pro-II-scripts.js (25.1 KB)

This is brilliant, thank you so much!!
I’ve been forced to use other software for the past few months since finally buying my Mixtrack Pro 2, so finally I can use Mixxx again.

Are the mappings also compatible with Mixtrack II ? => numark.com/product/mixtrack-ii

regards

Hi,

I don’t have the equipment but I believe it can work too.

Armen

Hello Armen

great work thanks. I only have 2 problems.

when in scratch mode i turn the jogwheel back or forward and take me hand up, there get the sound forward for ~0,02s when the waveform stops to moving (when play is not on you can hear it better).
the second problem is to turn off the auto loop mod (1,4,16) i must push the button exactly at the end of the loop to get it off, otherwise i make another loop.

I search in js.script but i am not really good at those things. maybe you have a solution for this…

Thanks Herbert

this mapping not correct in 1.12 beta

FX button and FX jog
not exit in loop mode

Thanks so much for the effort in making this mapping, works a treat.
But I have a little issue…

At random, only after quite a long time, my mix track doesnt respond. It’s lit up
Only way I can get it back working is a mixxx restart

Can anyone help?
It really is random, had it working for 12 hours last week, left it on, had it working for 4 hours tonight, then it simply stops, the music continues, I’m using auto dj to test if that makes a difference

As an additional note, this is a solid starting point if you have a non-pro Mixtrack II. Definitely gets the job done to start with.

How does the Mixtrack Pro 2 mapping work with the Mixtrack 2? Are the MIDI signals exactly the same and the same mapping works for both? If not, what are the differences?

where do i put the xml code for mixtrack pro 2?

Could you please submit this mapping for inclusion in Mixxx?

I also found that when I let go off the wheel after a scratch, the speed of the wheel would be too high, causing an increase in pitch before settling to normal playback speed.

To me it behaves much more like Serato Intro if one does this change to the js file:

Change this (on line 421):

engine.scratchDisable(deck);

To this:

engine.scratchDisable(deck, false);

Firstly - Thank you for this, it is great!!

I have one small issue (that may be a non-issue) When I press the ‘Sync’ button, the button stays lit both on the controller, and on Mixxx itself on my laptop screen. Does this mean that the software is assuming I am keeping the button pressed?

I had a look at the xml & js files - and it seems that this behaviour is probably controlled by the script, but that’s about as much as I can understand.

Could anyone provide a change to the script command that I can paste in so that pressing the sync button on the controller is just momentary & works the same as clicking the sync button on the screen? (including the action of the button LEDs)

Thank you! :smiley:

No, it means master sync is on. Which is puzzling because the mapping was made for Mixxx 1.11 before Mixxx had master sync. “sync_enabled” is the control for toggling master sync; “beatsync” is the old control for momentary sync.

Hi guys, i created an updated MIDI and JS file to fix the broken flanger effects in Mixxx. github.com/snowyoneill/Mixxx-Nu … -2016.midi

Great! Could you please submit the mapping for inclusion in Mixxx? You’ll have to fork the mixxxdj/mixxx GitHub repository and put the mapping files in the res/controllers folder.

Hi guys! I updated the mapping and submitted a PR for inclusion into 2.1 – github.com/mixxxdj/mixxx/pull/1540.
I have updated the documentation also – mixxx.org/wiki/doku.php/numark_mixtrack_pro_ii.

Cheers!

thank you so much for this! it’s working pefectly! :grinning: