Controller "Enabled" checkbox is grayed out and scripts tab is missing

Please help, I have windows 10 and latest version of Mixxx. I installed loopMIDI but I can’t enable it in controllers tab because “Enabled” checkbox is grayed out. And I can’t install scripts because there is no “scripts” tab.

Also “MIDI Through Port” is missing even in --developer mode with developers tools tab showing.

which Mixxx version do you run?
the contoller mapping UX is very much improved in Mixxx 2.3 beta, please try that if you haven’t already.

that is only active if you choose a mapping from the drop-down menu at the right.
there you can choose amongst built-in mappings, or custom mappings – if you have any in (Mixxx settings folder)/controllers/
At the bottom of you’l find the Windows location where to put that mapping.
If you didn’t create one, yet, you may choose an existing mapping and edit that. I’ll be saved there automatically.

IIRC there will be a scripts tab if you load any in the xml base mapping file.
If you load a mapping --in 2.3-- there are clickable links in the mapping info section that would open those files.

Thank you! By pressing something I somehow managed to create a new xml which which was located in C:\Users\idk\AppData\Local\Mixxx\controllers
Then I modified it to be like that:

<?xml version='1.0' encoding='utf-8'?>
<MixxxControllerPreset mixxxVersion="1.8.0+" schemaVersion="1">
    <controller id="Network">
            <file functionprefix="midiAutoDJ" filename="AutoDJ.js"/>

And it works when I select it