Crash Assistance

I was streaming on twitch last night when Mixxx soft locked. I’m hoping someone can give me a little direction on what I can do to get some information together for reporting or reproduction.

  • playing for just less than 2 hours
  • mixxx locked when I double click loaded a track to player 1 (this is how I load all tracks)
  • 2.3.0-beta (build 2.3 r7467) – haven’t checked for updates in a couple days
  • Ubuntu Studio 20.04 routing through Jack from Mixxx to OBS
  • recording audio video Mixxx

I’ve looked at the log file, but I’m not seeing anything interesting there. I’m happy to attached the end of the log, if anyone is interested.

Likewise, video of the crash isn’t terribly interesting or helpful.

It looks like the software was still responding to key presses from my controller. If I’d been thinking at the time I would have tried the eq pots to see if they were controlling the software appropriately still.

I’m not sure at this point, short of reproduction, if there’s anything else I can grab as this isn’t a very helpful bug on its own.

Any help is appreciated.

Can you reproduce it by loading that same track?

Also, did you check that you have enough free space on your home drive? Mixxx writes the waveform data to disk and weird stuff can happen if there isn’t enough space AFAIK.

Yes, the track loads appropriately. I had setup my cues Thursday and played it earlier on Friday. I just tried it again. Loads fine. Loaded it in conjunction with the other song playing in the second deck. Also fine.

Definitely not an issue. I’ve got at least 150 GB free. This laptop is used exclusively for mixing and music production, so I work to keep everything clean.

I’m starting to suspect that it might have been Jack that died. Failing an appropriate audio output path, Mixxx somewhat froze. It’s the best explanation I have at the moment.

Possible. Mixxx also stops working when you pull the ALSA USB soundcard while it’s running.

No, if JACK crashes or freezes, Mixxx will freeze completely, which is not what happened in your video.

I record everything. If it happens again I’ll try to get some more information in the moment.

Alright, two streams in a row. We’ve got a pattern at least.

  • mixxx.log last recorded message was three minutes before the crash
  • last log messages were about the song prior to the two songs in the player
  • dmesg and journalctl were likewise unhelpful
  • track being mixxed out of in deck 2 is the same track as the previous crash (Mittone - Pitch It Down)
  • this track wasn’t logged to mixxx.log
  • closing and opening Mixxx back up did not fix the issue
  • required restarting JACK and Mixxx to get audio /playback restored

I doubt it’s a permissions issue on the file as it looks fairly consistent with the rest of the music in that directory. None of which I’ve had any issue with.

-rw-------  1  8052630 Jul  2 19:02 'Deed - Padimpo.mp3'
-rw-------  1 11975795 Jul  5 16:21 'Dots Per Inch x Major Key - How Could You Lie To Me.mp3'
-rw-------  1  9872161 Jul  2 21:31 'Farah Farz - Do The Grapevine.mp3'
-rw-rw-r--  1 13899631 Jul  4 22:08 'INNDRIVE - Go Away (Extended Mix).mp3'
-rw-------  1  7729728 Jul  5 16:20  KiddaJacoBMyClick.mp3
-rw-------  1 13374099 Jul  6 21:25 'Lipe Forbes and Bruno And Juliana Barbosa - Come On Over.mp3'
-rw-rw-r--  1 10761513 Jul  6 21:45 'Mittone - Pitch It Down.mp3'
-rw-------  1  9502809 Jul  2 19:05 'Psilocybin Laden - Fuck off.mp3'
-rw-rw-r--  1  7029207 Jul  5 16:22 'Vanilla Ace Mr Fitz - Birdcall.mp3'
-rw-------  1 11199361 Jul  5 16:23 'We are your friends (Skemaddox bootleg remix).mp3'

It’s not any different from any other folders with music that I’m using, at least.

The only other thing I can think of, and I suspect it’s a longshot, is some kind of file lock / access priority issue as I’ve got Mega running in the background, syncing all my music. I’ve noticed that Mixxx makes some minor changes to files (metadata tags?), which then automatically sync. If it’s trying to perform operations while Mega is working on it… maybe?

This particular track was a wave download that I locally converted to 320kb mp3 with ffmpeg. I do the same process with all the wave files I download, so I’m not suspicious of the encoding.

The track is suspicious, but I can’t put my finger on why. These are all the things going on while I’m streaming.

  • this track
  • Mega running sync in the background
  • recording audio via mixxx
  • routing audio via JACK to OBS
  • streaming via OBS
  • recording video via OBS
  • droidcam capturing video via phone over USB

The droidcam stream is new for the last two streams, but it doesn’t feel like the likely culprit here as it’s not interacting with Mixxx at all, just OBS.

My next step is to try playing with just the track common to the crashes and seeing if it’s reproducible that way.

Messed around with just the track, JACK, and Mega running. It played fine repeatedly, however, I couldn’t trigger the update that causes Mega to sync the file changes. Will keep at it over the next few days, unless anyone has any ideas or guidance on likely causes.

That seems plausible. There is an option in the Library preferences to disable Mixxx writing to file tags.

It also seems plausible there is an issue with how Mixxx is reading the file if it happens repeatedly with only that file.

Make sure that no other application writes anything into the audio files! Mixxx internally uses memory-mapped file access for decoding MP3 files. If the files on disk are modified concurrently by an external application while loaded in Mixxx this will result in undefined behavior.

I’m fairly confident (nearing certain) that nothing else is operating on those files. Mega is just a cloud sync application that is recognizing changes and syncing them. Nothing more.

I maintain a full back up of my DB, so I don’t need any tag updates. I’ll disable that and see if it I’m still able to reproduce.

Disabled writing tags. Played an hour and a half set while streaming with no issues. Cautiously optimistic this will resolve the problems I’ve been seeing. I stream three times a week and it’s the only time I saw the problem. If it’s going to happen, I expect it’ll happen soon.

1 Like

Things have been fine since my last post until tonight. An hour into a two hour streaming set and I’ve crashed twice. I’m starting to think something is happening with the connection to JACK causing the issue, but I have no idea how to start tracking this down.

From now I’m going to run Mixxx from the terminal to see if I get any useful output. JACK isn’t telling me anything interesting and neither are the Mixxx logs.

Was it with the same track again? Has it only happened with that one track? Are you able to load and play other tracks with that deck after this happens?

It hasn’t happened with that track since the first two times. I have four separate occasions and five instances within those four occasions. The first two were that track. The rest have been different tracks.

Have these all been MP3 tracks you encoded with FFMPEG?