Disabling crossfader on DJ2GO2 TOUCH

Hi, I have my Numark DJ2GO2 TOUCH mapped to MIXX (thanks to Kafuzke and pancake) and would like to know if there’s any way in which I can disable the crossfader. I know you can remove it from the skin but I’d like to be able to disable the crossfader on the TOUCH itself. I’ve looked in the manual and on MIXXX itself but can’t find a way of doing this (or am I missing it?) so would it be a case of tweaking the mapping? Any advice would be much appreciated.

In Mixxx 2.3, there are crossfader assignment buttons next to the crossfader in the GUI. Set both to center position to disable the crossfader. This should also apply to the physical crossfader on the controller AFAIK.

1 Like

That’s great - many thanks! I will give that a try.

The crossfader assignment doesn’t persist across restarts, yet https://bugs.launchpad.net/mixxx/+bug/1896832 (we stll need to discuss if this is desired for everyone)

You could set the deck orientation in the script so it’s restored everytime you use the controller
(somewhere in the init() function of the script):

engine.setValue("[Channel1]","orientation",1); // assign to xfader center
engine.setValue("[Channel2]","orientation",1); // assign to xfader center
1 Like

Thanks very much, ronso. I will try that as well!