Effect list dropdowns not working on Debian

Hello,

When i try to select an effect on any deck the dropdown list doesnt seem to respond. In preferences i can change the filter to a quick effect, and that works.

I have compiled from github from latest (2.4.0-alpha-pre) to try and fix but same results as 2.2 on Debian.

Mixxx is great btw, Thank you!

https://0x0.st/-YW7.png

I think you experience Bug #1902125 “effect selector can't be opened on Arch” : Bugs : Mixxx
" effect selector can’t be opened on Arch"

Alternatively you may try to hover over the effect selector and scroll to change the effect.
Does that work?

Hey thanks, Hover and scrolling doesnt seem to work. Im running X and dwm on Debian…thinking its a UI input issue maybe?

sorry, I forgot I disabled that earlier :grimacing:
This is the PR prevent changing the effects by scrolling hovered EffectSelector by ronso0 · Pull Request #2923 · mixxxdj/mixxx · GitHub

If you compile yourself you may revert commit prevent changing the effects by scrolling hovered EffectSelector by ronso0 · Pull Request #2923 · mixxxdj/mixxx · GitHub

Unfortunately we couldnt figure out in https://bugs.launchpad.net/mixxx/+bug/1902125 which package is responsible for this dysfunction.
May you have an idea how to approach that?
For example which Qt version do you use? Which other (distro-specific) packages interfere with this function that works for other OS and distros?
Can you access all drop-down lists in the preferences?
Can you change the transition mode in Auto DJ?
Are you able to test with another window manager?

I can try those tests and get that info soon. The drop-down lists in prefs all work fine. I just like to mention now, I seen another post here about the theme causing problems with the effect selector.

I guess you refer to this thread and how the user managed to fix the issue for his OS

Please let us know if that works for you, too.

We can try to set the focus policy to Qt::ClickFocus and automatically remove focus after an effect has been selected.
This way we may fix this issue with rare system setups while keeping the library navigation functional via Tab key (real and emulated), i.e. don’t allow moving focus to effect selectors and spinboxes and don’t allow focus getting stuck there (keyboard shortcuts don’t work for example).

That fixed it, tyvm!

Several different suggestions were made. What did you change that fixed it?

I commented out setFocusPolicy(Qt::NoFocus); in the effectselector contructor

https://github.com/mixxxdj/mixxx/blob/bde5bed093e4581526b2fd6fe2e37f0f9e3c16da/src/widget/weffectselector.cpp#L15

Good to know, thx!

(updated https://bugs.launchpad.net/mixxx/+bug/1902125)

could you try if it also works with setFocusPolicy(Qt::ClickFocus);?

setFocusPolicy(Qt::ClickFocus); works fine for me too.

the fix setFocusPolicy(Qt::ClickFocus); has been merged to main branch.
To not interfere with keyboard shortcuts and library navigation the focus is passed to the library after selecting an effect.