Effect rack 1 doesn't work for deck 1 (yet works in headphones & master)

Hi all!

First off I’d like to give a huge thanks to the developers and community who enable the use and sustain this amazing open source software. Especially cause it seems to be the only Dj software available on Linux :slight_smile:.
Unfortunately I’ve ran into a small problem, which I couldn’t seem to fix by reinstalling, since it will keep my configuration files (I tried both apt remove and apt purge). This problem randomly occurred after having used this program for 2 months. Am using a humble dj control air (hercules)

A summary of my problem:
Effect rack 1 (associated with deck 1) will have effects active, but not relay the effect to what is playing on deck 1.
However, when I press the headphone button, it will relay the effect to deck 1 playing in headphone feed, and when I press the master button it will relay the effect to the current mix.

I see two possible solutions to the problem:

  • fixing it somewhere in the configuration / load in extra script to deal with this
  • completely resetting configuration (but how do I uninstall all configuration as well?)

A picture is included that shows what my decks would look like, when effect ‘moog filter’ from rack 1 is not relayed to deck 1, though being active. (while the filter on rack 2 perfectly relays to deck 2)

If there is anything I must add, let me know.!
Thanks in advance!

PS. As you may see, the beatanalysis is off. It is for half of my tracks (bpm too). Is this usual? any way I can resolve/workaround this?

You haven’t routed any decks to effect unit 1. https://manual.mixxx.org/2.2/en/chapters/effects.html

I also experienced that the FX routing sometimes gets lost between restarts. Unfortunately, I am not able to reproduce it reliably and I am not even sure if I disabled it accidentally.

The effect routing buttons are easy to overlook. We should add screenshots to the manual, to make it more obvious.

I added an issue here: https://github.com/mixxxdj/manual/issues/320

Thank you very much, I have now found the button! I had looked for settings in multiple places, and even skimmed through the manual. I have overlooked it completely, I didn’t expect this to be the solution in the end, and perhaps feel slightly ashamed. Either way, thanks again :slight_smile:

No problem. It’s a complex system so I could understand how you’d get lost using it the first time.