Error when connecting to a streaming server

Hello,

I’m using Xubuntu 20.04 as OS with Mixxx 2.2.3. My aim is to broadcast via the «live broadcast» in Mixxx and using Liste2MyRadio.com.

I set everything but, when I try to connect, I got the error :
« Please retry current operation.
Please check your connection to the Internet and verify that your username and password are correct.»

I checked many times my user name and password and there’s no mistake. In the forum, I read the troubles can be caused by the port translation, firewall (…) but, which port translation shall I do on my modem ?

I also tried to configure «Butt» to make a test. With BUTT, no problem : it connect to Listen2MyRadio and I can broadcast what I’m saying in the microphone. So the problem is with Mixxx.

Here is a screen capture of how I set the live broadcast : https://gyazo.com/ec2209ed313556e41ead74bd5faf195d
And here is a screen capture of the Listen2MyRadio settings : https://gyazo.com/4a65ee0c63889cd3b763e658c39355ba
I tried to change the «mount» section : empty, live, live.mp3, mount, mount.mp3 ; and also swap the IP with the hostname but nothing works.

Here is an extract of my mixxx.log file :
Debug [ShoutOutput ‘Listen2MyRadio’]: ShoutConnection - run: Starting thread
Debug [ShoutOutput ‘Listen2MyRadio’]: ShoutConnection - processConnect
Debug [ShoutOutput ‘Listen2MyRadio’]: ShoutConnection - “Listen2MyRadio” : updating from preferences
Debug [ShoutOutput ‘Listen2MyRadio’]: ShoutConnection - Using server URL: QUrl("//admin@162.210.196.140:18728")
Debug [ShoutOutput ‘Listen2MyRadio’]: Successfully loaded encoder library “mp3lame”
Debug [ShoutOutput ‘Listen2MyRadio’]: Loaded libmp3lame version 3.100
Debug [ShoutOutput ‘Listen2MyRadio’]: lame_set_VBR_quality: “present” lame_encode_buffer_interleaved_ieee_float: “present” id3tag_add_v2: “present”
Debug [ShoutOutput ‘Listen2MyRadio’]: CBR mode with bitrate: 112
Warning [ShoutOutput ‘Listen2MyRadio’]: ShoutConnection - 1 / 3 Streaming server failed connect. Failures: “Please retry current operation.”
Warning [ShoutOutput ‘Listen2MyRadio’]: ShoutConnection - 2 / 3 Streaming server failed connect. Failures: “Please retry current operation.”
Warning [ShoutOutput ‘Listen2MyRadio’]: ShoutConnection - 3 / 3 Streaming server failed connect. Failures: “Please retry current operation.”
Debug [ShoutOutput ‘Listen2MyRadio’]: Unloaded libmp3lame
Debug [ShoutOutput ‘Listen2MyRadio’]: ShoutConnection - processConnect() returning false
Warning [ShoutOutput ‘Listen2MyRadio’]: Streaming error: “Please retry current operation.\nPlease check your connection to the Internet and verify that your username and password are correct.”

What can I try now ?

Thank you for your help.

Dr_Click

Did you read the respective manual section https://manual.mixxx.org/2.2/en/chapters/livebroadcasting.html#live-broadcasting-preferences ?

especially
“Mixxx works with Shoutcast 2 using the Shoutcast 1 protocol if you provide a stream name in Preferences ‣ Live Broadcasting ‣ Stream Settings. If you don’t provide a stream name, Shoutcast 2 rejects the connection (where Shoutcast 1 would accept this case).”

Hello Ronso,

Thank you for your first reply. I added a name in the «Stream info» part and I ticked the «Public stream option». So now, my configuration looks like this


and

But I still get the same error. Do you have a Listen2MyRadio account ? Or do you want I send you my login and password in private message and you try with your Mixxx ? Or do you use another stream provider ? I’m continuing to try to connect, modifying the settings, deleting the password to write user:password in the user area or other things like this but… still error, error, error…

I don’t have time to try your broadcast settings tbh. Also it’s best we investigate the issue further on your machine. Unfortunately I can’t spot any obvious messages from your log
Did you try removing the slash / in the mount point field?

Btw: you can update Mixxx to 2.2.4 and you could even try 2.3 beta. Downloads are available at mixxx.org/download as usual.

Good evening Ronso,

Your solution was the good one : I installed Mixxx 2.2.4 and the problem is now solved. I’ll never know why it didn’t worked in the 2.2.3 but, as this new version is the latest stable, I’ll keep it.

Unfortunately, a new problem appears but, I’ll open a new thread for it.

Thank you very much for your help for this problem which is now solved :slight_smile:

From the 2.2.4 changelog:

Add workaround for broken libshout versions #2040 #2438

Basically there was a bug in the library we used to connect to Shoutcast, and some distributions still shipped the broken versions, so we needed to include the fixed version in Mixxx itself.

1 Like

Thank you hlzhs to have taken time to explain where does this bug comes from. I appreciate a lot how your team is involved to give a full answer.
Good job :slight_smile:

Thanks @hlzhs I wasn’t aware of that bug.