Fx dropdown not working on Arch

Hi there,

When I click on any of the dropdowns in an Fx chain, nothing happens, as if the Fx list were empty or something. I am using mixxx version 2.3, but I’ve tried version 2.2 as well with the same result. I’ve never been able to use effects, so maybe I’ve just missed something. The effects are marked as visible in the effects tab of Preferences. The Fx power symbol is on, volume turned up, I’ve tried routing to master and tracks, no luck. I’m on Arch Linux if that matters. Has anyone seen this problem before? I love Mixxx otherwise…

thanks,
Sam

sounds like Bug #1902125 “MIXXX 2.2.4 - Effects not Selectable” : Bugs : Mixxx

Appearantly it does, the bug above was reported for Arch while we never received such complaints for any other OS/distro.
Which Mixxx skin do you use? Did you try others?

Great link, ty! That looks like exactly my problem.

It seems to happen in all skins. Because I’m on 2.3, I can’t test the scroll mechanism…

I don’t know anything about arch.
which packges do you use that might affect Qt features like comboboxes (drop-down-menus)?
which compositor/desktop?
are there maybe any supplementary Qt packages you are missing?

Here are the qt dependecies for the arch package:

  • [qt5-base]
  • [qt5-script]
  • [qt5-svg]
  • [qt5-x11extras]

I have verified all are installed. Maybe it’s linking to the wrong lib or something…
I tried " mixxx --logLevel debug", but got no activity when I clicked the dropdown.

If I could find the handler for that drop-down, I could do a bit of testing…

Also, I use i3 for Xorg, and Compton for composition.

okay, maybe someone else can help you investigating the build and maybe dependency issues.

until the root issue is discovered and fixed I can propose two fixes:
1 undo my commit that disables (accidental) effect change with the scroll wheel and rebuilt MIxxx

2 start mixxx with --developer argument, open Dev Tools and filter the controls list for next_effect or previous_effect. You’ll find those for effect units 1-4, each with 3 effect slots.
The tedious part is now to set the values of the effect change controls to 1 to manually step through the effect list one by one for each effect slot you want to use… :kick_scooter:
Close Mixxx once you’re done and it will save the effects configuration to effects.xml in the .mixxx settings folder. I’d recommend to make a backup of that file :wink: you can even store multiple presets that way

Hey, thanks for the link. After messing around with things a bit, I found commenting out this line allowed me to select effects again:

I don’t know mixxx or Qt well enough to understand exactly what that was supposed to fix. Can you provide anymore context for that change? It seems like it should have only applied to the keyboard, but is also applying to the mouse perhaps…

I disabled that because with my touchpad it happened a few times while being live that I accidentally did a swipe while the cursor was above the effect selector. That would instantly switch the effect and changed the sound and messed up my mix. Thus we sacrificed the convenience to have the failsafe traditional way only: open the drop-down and select an effect.
The effect selector is based on a standart combobox and actually works on all platforms,. except some Arch configs appearantly.

Edit
Instead of ClickFocus it’s NoFocus in order to steal the focus from the library widgets, which would mess up the coontroller library navigation.