Gemini FirstMix

This is a complete mapping for the Gemini FirstMix controller (geminidj.com/firstmix). All functions, buttons, and lights supported and working. This was created and tested using Mixx v1.10.0 on a Windows 7 x64 system. Enjoy!
Gemini FirstMix controller mapping for Mixxx.zip (4.16 KB)

Thanks!

I can confirm that it works fine with 1.11.0-beta2 / Linux x86_64. Good idea to remap the gain with EFX, to have lo-mi-hi eq.

To let it be completely compatible, I added an info tag to the xml file:

<info> <name>Gemini Firstmix</name> <author>mcsquared88</author> <description>MIDI mapping for Gemini Firstmix</description> <forums>https://mixxx.discourse.group/t/gemini-firstmix/12604/1 </info>

OP, the original attachment is no longer available for download. Would you (or anyone who has it) be able to re-up to here, mediafire, or some other such place?

Also, fwiw, the FirstMix is detected and can midi learn in Mixxx 1.10.1 stable, running on Fedora 17 x86_64. In fedora 16, the controller will detect, but I’m unable to map MIDI controls for some reason. Couldn’t speculate as to why 17 works and 16 doesn’t.

Thanks mcsquared88 – I’ve added your preset to the Mixxx 1.11.0 release.

@p0tato – the forum had some issues a month or so ago but the file is back.

I don’t knw where I should put this so I am replying here. I have had bugs with the script where the scratch button will disable the play bitton completely. I turned scratch off and problem persist til I reset. the script also has a bit of trouble with conecting. Don’t know how to explain it but sometimes it will randomly shutoff so I have to restart mixxx completely any help?

I am having similar problems with the FirstMix mappings. When I hit “Scratch”, then touch the platter, it will never just play again, it’s in permanent scratch mode. If you hit the scratch button again to turn it off, the platter will nudge the music, but the music in in “stop” mode. It just wont play again until you restart the program. Hitting play lights up the play icon/button on the controller, but doesn’t play the music. Any ideas?

Daniel

Does this work with gemini firstmix pro?

Here is the fix:

Edit “Gemini-FirstMix-scripts.js” and add

to the firstmix.scratch function:

// Scratch buttons firstmix.scratch = function (channel, control, value, status, group) { if (value == 0x7F) { // Only take action on button press; not button release if (firstmix.scratchButton[firstmix.currentDeck(group)-1] == false) { // if button is off, turn it on firstmix.setLED(firstmix.leds[firstmix.currentDeck(group)]["scratch"], 0x7f); firstmix.scratchButton[firstmix.currentDeck(group)-1] = true; } else { // If button is on, turn it off firstmix.setLED(firstmix.leds[firstmix.currentDeck(group)]["scratch"], 0x00); firstmix.scratchButton[firstmix.currentDeck(group)-1] = false; engine.scratchDisable(firstmix.currentDeck(group)); } } }

This fixes the issue from squirrelhavoc.

hey…I just signed up for this solution… :slight_smile:

Hi,

I’m useing whats in the zip file with the added code just above.

But my Deck 1 Jog Wheel does not work and it seems the Scratch buttons dont do as intended. just light up. I am really confused over whats happened. Help would be appreciated.
Thanks.
firstmix_.midi.xml|attachment (12.9 KB)
firstmix_-scripts.js|attachment (11.7 KB)