Headphone can't be connected

I down loaded the new Mixxx I just Dj online nothing fancy but the bug I am having with the new down load is I use Voicemeeter banana to run mixx through and the new Mixxx down load is not allowing me to use my mic I know Voice meeter is set up right because i down loaded the old version which I loved had no issues but that version is buggy and dele all my saved profile in mixxx has anyone had this issue hope they fix it soon if they can

Mixxx would not delete your config on reinstall. However, Mixxx 2.2.x stores your broadcst profiles in a different way than Mixxx 2.3, so it’s probably just that your profiles are not loaded in 2.2.x (they’re not gone)
Do you now have Mixxx 2.3 installed?
If, so please post a screenshot of Preferences > Sound Hardware


That is what i get and i know my Voicemeeter settings is right

See I am on Air No Mic showing

Please take a look at the top row with the toggles for GUI sections.
Find MIC/AUX and click it. Voila.

if the mic could not be configured it would not show up in the Mic row, of course.

Yeah tried that nothing works

it’s the microphone Monitor Mode it’s locked now allowing me to run my mic through voicemeeter as u can see its grey meaning set to master output

Not* allowing me…

…because there is no mic configured.

You can try a different sound API, Windows Direct Sound is not the best choice.
I hope that’s the reason.

That chapter also explains how to avoid mic crackling with a large enough buffer.

I have tried every one nothing works I am on windows 10 64bit I do not have any fancy Dj Set up I said the new update seems it’s for those fancy Dj’s and not for Just some dude who likes Music I am not a programmer So I do not Know I just miss the easy set up 2…0.0.0 That worked as well as the which as well gave me No issues So I down loaded a old version and it worked great for 20 min then Boom crash dele and said screw this removed it So maybe u guys should just stick with the Mic config it worked for me then

Please use some punctuation so reading your posts is easier. Thanks!

I’m not aware that the setup GUI itself was changed significantly since 2.0
However, the underlying libraries (external dependencies) Mixxx is built with sure have changed since then, both to fix bugs and support current devices and APIs.

The Mixxx configuration is supposed to work with any setup, no matter if Pro or comsumer devices.

I suggest you make 100% sure you have your Arctis drivers updated.
If the error keeps popping up please provide the log file of that session.

  • start Mixxx
  • try to configure your devices
  • see if the error pops up, close Mixxx
  • don’t load any tracks or interact with the library to keep the log as clear as possible
  • start a new session to try with another API

Maybe someone can figure out what’s going on.

Is Voicemeeter also configured to use Headset Earphone? If Voicemeeter and Mixxx are both trying to get open the same device simultaneously, that could explain the error.

Also you are trying to output a mono signal to Headset Earphone by only configuring Channel 1. You probably want a stereo output with Channels 1 - 2.

1 Like

Yes Voicemeeter Banana is right… Like I said I down loaded a old version of mixxx which is not supported any more but did it to see if it would work and and my mic connected no issues which tells me my set up is fine it’s the new down load for mixxxx which has the issues not on my end I have did everything I do not know who the sound guy who is working on it But just wish they would get it fixed so my headset has no issues

Supply the logs as I outlined above, then we can try to find the cause.

I have supplied many many photo’s even what comes up in Mixxx and voicemeeter banana I have no issues signing into caster and playing music on caster.fm I am playing music now i have a issue with mixxx not letting me connect to my head set But as i said and showed my mic does not come on I get that pop up each time i have tried everything and have had sound tech guys help and they say the same thing it’s mixxxx not me

That screenshots show your configuration, but we need to know what’s going on under the hood to help you fix the issue.

so, once more before I give up: provide the log files as I explained above, otherwise we can’t help you.