Help with Mixxx and CDJ850

Hi all,

I’m trying to hook up my 2 CDJ850 players into Mixxx, but for some reason the play/pause button (amongst others) is not working correctly.
One CDJ’s play button starts both decks in Mixxx where the other CD play button does not respond.
I’ve made a little video to make my point clear:

And a screenshot of the output setup.
Thanks for any help!

The mapping is for 2 CDJs and should just as far as I can tell.
Can you configure the CDJ to use a certain MIDI channel?
Left > channel1, Right > channel2

from https://usermanual.wiki/Document/CDJ850TraktorProPro2Guide.1095585103/help

Configure the Multi Player’s MIDI channels.
1 Press and hold the [MENU (UTILITY)] button for 1 second or longer to switch to UTILITY mode.
2 Turn the rotary selector and select [MIDI CHANNEL]. Press the rotary selector to choose your
selection.
3 Turn the rotary selector and select a MIDI channel (1–4). Press the rotary selector to choose your
selection.
4 Press the rotary selector again to save the changes to the MIDI channel configuration.
Press the [MENU (UTILITY)] button to exit UTILITY mode.

Hello ronso,

Thanks for replying!
I got them working after many trials and errors. Here’s what I’ve done:

  • download the pioneer CDJ aggregator utility to merge multiple CDJ devices into one virtual device called Pioneer CDJ/XDJ and use this as midi device everywhere in Mixxx
  • assign Deck 1 to Pioneer CDJ/XDJ channels 1-2 and assign Deck 2 to Pioneer CDJ/XDJ channels 3-4
  • in the “Controllers” tab, only enable the first two CDJ850 devices and disable all the rest (I have 6 others named CDJ850_6). Only 2 can remain enabled or else the play/pause/cue is messed up.

This did the trick. Too bad this setup does not save upon exit. I always have to disable those 6 extra midi controllers.
Although fun to play with and great because it’s free, Mixxx has poor beat detection. Many of my house/trance tracks were badly analyzed and couldn’t be correctly synced. This makes Mixxx less suitable for a stage setup.
But I will check now and then to see of the algorithm has improved. Thanks for the help!

This sounds rather complicated. Did you try the simple steps from the manual I linked?

Yes that was the first thing I did, but no luck. Changing the channel in the CDJ itself is not enough.