Hercules DJ Control AIR

This mapping is still “work in progress” and not every button works. The “rec” button is unused at the moment, since Mixxx does not yet allow to control it’s recording function (feature request has been accepted already so i hope this will be possible in the next version). The “magic” button is unused as well as i havent discovered any use for it so far. As the jog wheels do register touch, i’ve mapped the scratch button to be used as a shift button to load/map samples. The “AIR” controller is also unused at the moment, but well … i think it’s quite useless anyway :mrgreen:

Greetings from Hamburg / Germany

I couldn’t get this to work at all. =/

Hi rojaro – I added your mapping to trunk so it will be included in Mixxx 1.11. Could you comment on what remains to be done to get it fully functional?

Tesno – could you describe what didn’t work?

Thanks!
RJ Ryan

Well, it sort of works now, if I click cancel after picking the mapping. =S I played couple of hours without any major problems, but program seems to crash in every other setting I touch (resolution/skins, skin options, sound card options. Then again, all those may be connected to mapping, because somehow mixxx doesn’t want ok after changing the mapping). I’m using Lenovo Thinkpad Edge 13", SU7300, 2Gb memory and Xubuntu

Most of the buttons seem to be in place. Proximity sensor doesn’t seem to do anything. Loops-Effects-Sample -button could do more, if it would be mapped differently. I would also change -/+ buttons to adjust gain, because the controller lacks couple of important knobs. Jog wheels are too sensitive for my taste. I find it hard to correct the tiniest offbeats. Also the fast skipping, (song on pause, pressure on jog wheel and turn) goes from start to the end of the song in just a very small movement.

And after all, it would be nice, if also the led lights on buttons would work.

hi,
sorry for my poor english… :frowning:
I use hercules control air.
I put the file you posted in the c:…/ mixxx/ midi etc etc, but when I go into the midi preferences, I select this mapping but the console and the program does not work, and not load any command in the window below.
thak’s a lot…

I’ve tried the mapping above. However, in order to get it going, you must NOT press OK on the preferences window. You need to press CANCEL. --midiDebug informs me as follows: “PortMidi call failed… PortMidi: `Invalid MIDI message Data’”. I tried googling the issue to no avail.

Also, there is no way to edit the mapping because every time you touch something in the preferences window (be it in the MIDI Mapping section or not), and hit OK, MIxxx crashes.

Is anybody working on this presently? I’m trying to find the time to edit the mapping myself and would like to know if somebody is on it already to join efforts.

Thank you Rojaro for the good start =)

Hi,
I edited rojaros preset.

New Features:
- Fixed mixxx crash
- LED bars now show song position
- Sync LEDs
- AIR control

please try and report errors / feature requests.
Hercules DJ Control AIR Preset 2.zip (4.2 KB)

Hello. people. I Recently bought the Hercules DJ Control Air Controller. Thanks to mitchmao explinations I make it work without crahsing the program (not pressing the OK button).
Here is my little and first contribution (according to my DJ tastes):

  • Edit the Rojaro script for the jog wheel to be not so sensitive (0.9 to 0.3).
  • I also changed the headmix so you can hear the mix and cue while (-1 to 0 instead of -1 to 1).

The attachment contains a preset with the above modifications. I’ll try to make improvements to it but for now its all i have.

Sorry for my English.

PD: The Attachments “Hercules DJ Control AIR Preset 2.zip” from joerns is no longer online. If anybody has it, please upload! Thanks!

Mixxx Mixxx Hercules DJ Control AIR Preset3.zip (3.05 KB)

ASSERT failure in MidiLedHandler: “Invalid config group: ‘[Sampler3]’, name: ‘play’”, file src/midi/midiledhandler.cpp, line 21

I do have a LPD8 as well. Could that be whats screwing with it?

Thanks,

Mike

Maybe. I never use two devices at same time on mixxx. I guess it can be fixed comented or deleting the line 21 (Or all the “sample” lines). Just guessing, im not sure…

What version of mixxx are you running?

Thanks,

Mike

Hi, the stable version from ppa, v1.10.1. I try the beta2 from v1.11 but its a little buggy and crash frecuently.

Then that’s probably why. I was running 1.9.1 and when I tried to upgrade to 1.10.1, it wouldn’t run in OS X Lion. Said the file might be damaged or corrupt… any thoughts?

Thanks,

Mike

If you want, try the 1.11 beta2:

moo.glines.org/mixxx/mixxx-1.11.0-beta2/

In my case, the beta2 works, but it crash in time to time. The control air controller is suported.

Hi friends, i’ve mixing and enyoying my Control Air Controller. Also i modify the preset posted before by Rajaro.

Improvments (i hope so):

  • The “air control” really control somthing: the depth in flange effect
  • The “sync” botton was mapped but does’t working. Now it work (was not essential botton but…)

I’ll try to learn more about how it work the mapping. For now i’m just guessing…

Mixxx Hercules DJ Control AIR Preset4.zip (3.07 KB)

I’m trying to map the leds. Can said the actual led mapping for control air in 1.10 is not working very well.
The javascript file contains some code for mix and cue, and works fine. But the “outputs” maped in the xml archive doesnt. For example, the play button dosnt light up when its pressed. And so on.
Im tryint to learn how works but im not a programmer. I read all the wiki info but cant undestand completly… I need some help here. First: ¿Why the output mapping doesnt work? ¿Is the order of tags matters?

Sorry for my bad english.

Thanks all,

I’ve updated the version of the AIR preset included in Mixxx 1.11.0 to be Frederico’s latest update from 1/12/2013 (preset4).

If somebody else here has the problem that mixxx suddenly stop to read the controller command with the following error message at the end of the log file.

PortMidi call failed…
PortMidi: `Invalid MIDI message Data’

I’ve created a package of libportmidi0 that fixes the issue, see bug #1097286

kellnerweg.de/~mlinke/

I updated the mapping that ships with mixxx.

The scratch button now enables spinback and samples can be loaded by pressing ‘magic’ while samples are choosen.

I have the issue, but I’m on x86, not amd64. Any chance of x86 libraries? and/or instructions for creating my own?

(Xubuntu 12.10, 32 bit, brand new hercules dj control air and sad face)