M-AudioXponent LinuxOS Sampler

Sampler buttons do not work on factory presets in Ma-AudioXponent. Everything worked before.
OS LinuxUbuntuStudio 20 LTS
LinuxMint18 Sarah

What are the sampler buttons on the controller? I can’t find any hint on the mapping page https://sinusoid.es/mixco/script/maudio_xponent.mixco.html

What means ‘before’? Did you upgrade Mixxx? If so, what was the last and what is your current Mixxx version?
Is the mapping workign apart from sampler issues?

I meant the sampler on the M-Audio-Xponent controller.


There are buttons for samples. Earlier in the Mix program, when I selected the M-Audio Xponent preset in the settings. As in the photo.

All buttons worked in the program. They don’t work now.
The learning wizard doesn’t work either.
I see a similar situation in Mix 2.2.4 on LinuxMint Sarah. And in version Mix 2.3.0 beta on UbuntuStudio 20.

If I make mistakes while writing, then I apologize. Since I am writing through google translator.

Okay, thanks. When did the buttons top working? What did you do before?
What is not working with the Learning Wizard?

No, they don’t work. Before that, it was enough to select the M-Audio preset in the controller settings, as shown in the photo and that’s it. After the latest updates of the program, something has changed. The preset was selected by default and on version 2.2.4. in Linux Mint. And in OS Ubuntu Studio 20 on beta version 2.3.0.
Now the M-Audio presets just don’t work. And when I select them, then instead of the samplers as before, the FX1 button 1 in FX2 is launched.

Please have a look at the wiki page I linked above (also availabel in Pref > Controllers > mAudio… and tell us which buttons you are referring to:
https://sinusoid.es/mixco/script/maudio_xponent.mixco.html

this mapping was auto-generated with mixco and from looking at the raw mapping in Mixxx 2.2 https://github.com/mixxxdj/mixxx/blob/2.2/res/controllers/maudio_xponent.mixco.output.midi.xml it is absolutely unclear to me which input is linked to which Mixxx control.
Also this and other mixco scripts were removed from Mixxx master branch as they are incompatible with our new scripting engine and the creator did not respond to fix the scripts. Seehttps://github.com/mixxxdj/mixxx/commit/803d1cb7cdc92a4e4420ad3f56c5a78dedb87d69

I suggest you use the Mapping Wizard to fix the the broken buttons yourself.
If yo succeed I you may also open a Pull Request at https://github.com/mixxxdj/mixxx/pulls so other users with this controller can benefit from the fixes, too.

Those buttons that I outlined in the picture in blue. They serve as a sampler, previously up to version 2.2.4 they worked as samplers by default after reinstallation or update. It was enough just to select the M-Audio preset. Now they don’t work as samplers. Although they are sampler buttons on the device.

Okay, thanks for the hint. Again I looked at the respective mapping description, section “Effects” https://sinusoid.es/mixco/script/maudio_xponent.mixco.html#section-7 and https://sinusoid.es/mixco/script/maudio_xponent.mixco.html#section-32 and those buttons are indeed supposed to control the effect unit assignment per deck. (this also applies to the mapping versions back to Mixxx 1.8) I don’t know which mapping you had before that.

If you like to have sample triggers on those buttons, please describe the behaviour you expect in details and we can give you hints how to implement those functions yourself.

There was initially a problem with the configuration scripts. In version 2.3.3 they were correct and exactly matched the synchronization with the M-Audio controller. Starting from version 2.2.4 including beta version 2.3.0 - controller management is broken.
The photo shows the screen where the samplers and knobs for controlling the sound on the sampler are shown. In version 2.3.3, these buttons and sample volume control knobs were perfectly synchronized with the M-Audio Xponent controller. Now, when you press the buttons of the M-Audio samplers, Fix1 and FIX2 are turned on. And this is just one of the nuances that are present in these new versions. It would be nice if you returned the same control script as in version 2.3.3.

Again: there has not been any Sampler controls in the Mixxx official mapping for the m-Audio Xponent.
Very likely you had an inofficial mapping installed which was was overwritten by the official Mixxx version.

Doing your work here: browsing through the Mixxx forum search results for ‘xponent’ https://mixxx.discourse.group/search?q=xponent
makes me believe you have had the mapping from @MelGrubb installed earlier.
I doubt very much that this version would make it into the Mixxx mapping collection as it prefers Sampler controls over Fx controls // while to most users --in my experience-- Fx controls are more important than samplers.

No. In fact, it has never been so that there would be samplers, which in all other programs perform the function of samplers by default. Whether in Virtual DJ or Traktor, they always function as samplers.
And in the MIXXX program before version 2.2.4, they were also samplers. After the update, confusion began. These buttons are for samples, and so are the volume controls. And not for something else.

You are probably thinking of the “M-Audio Xponent (Advanced)” mapping that I made. It used the left-hand set as samplers, and the right-hand set as effects toggles (or was it the other way around?). It should still be available, and is the mapping I use… or rather used regularly back before Covid-19, when bars were still a thing.

Anyway, I put a lot of work into that mapping, made a PR, and it was rejected because I hadn’t built it on top of the “components” framework which was unfinished and undocumented at the time. It soured me on the whole concept of trying to contribute back. I have other things to do than rewrite a complete and functional mapping on top of someone’s pet framework. If the framework had been mature, complete, and documented when I started, I probably would have built on top of it, but it wasn’t, so I didn’t.

Anyway, it’s still a fully-functional mapping. It’s just not “official”. You could always pull it from the fork where I developed it. https://github.com/MelGrubb/mixxx/tree/master/res/controllers

The description for the mapping is still on the wiki, marked as beta: https://github.com/mixxxdj/mixxx/wiki/M-Audio%20Xponent

Here’s the forum thread about the mapping: https://www.mixxx.org/forums/viewtopic.php?f=7&t=8884

PS I apologize for possible mistakes as I write with the help of Google Translate.

Not certainly in that way. Until the latest updates - all samplers, four sample buttons and volume knobs on the right and left worked. Those on the right made it possible to control samples of 4 buttons from the top row and volume knobs. Those on the right - with buttons and volume knobs on the right.
After the update, everything disappeared.

@userman This is simply not true, I checked the entire history of that mapping in 2.0 (1.12) and onwards: there’s no mention of samplers anywhere in that mapping.
Just install the mapping @MelGrubb linked above and to get what you want.

@MelGrubb
This is unfortunate…
I don’t think you’d need to rewrite the entire mapping to use components, just the Fx part. I did the same for the Reloop TerminalMix2/4 in https://github.com/mixxxdj/mixxx/pull/1490
Feel free to reopen https://github.com/mixxxdj/mixxx/pull/1194 if you like to continue.
Otherwise the mapping is inofficial and that’s exactly what the controller forum is there for :slight_smile:

The Xponent is actually in a better position as it has a 4th knob in the Fx section (not just a rotary encoder) which is a much better fit for the Wet/Dry knob of the fx units.
From what I can tell at a glance the current mixco mapping has a deprecated way of controlling the Fx I think it would even be possible to have two official mappings, one with sampler controls on both sides and one with the usual Fx controls.

I’d rather have a single mapping that can either toggle the behavior (e. G. by long pressing some button) or has this as an user option at the top of the file. That way, we can later add support for exposing controller preferences in the GUI. Multiple mappings are confusing IMHO.

If the current mapping is a mixco mapping, I’d also be okay with replacing it with a new one and moving the old mapping to the forums.

How to install everything that you described?

You can copy the files from the GitHub repository. Just copy the two “M-Audio Xponent (Advanced)” files to your Mixx controllers directory. On Windows, that’s usually something like “C:\Users{UserName}\AppData\Local\Mixxx\controllers”. You may have to restart Mixxx, I don’t really remember. It’s been a while since I worked on this. Then you should be able to select it as your controller like any other.

What does Windows have to do with it? The title of the topic is clearly written, I have a Linux OS.

Just making it clear that I work in Windows, so I can’t tell you the exact location of the mapping in your installation. I can only give you an equivalent example.

  • download the mapping files
  • go to Preferences > Controllers and click on the button Open User Preset folder
  • put mapping files in there

mapping locations: