MacOS Catalina PortAudio Errors

Hello,

Brief Background on System:
Prior to last week I was running a Hackintosh with Sierra and Mixxx was working fine. I happened to spill some vape juice on my motherboard that went unnoticed, and when that fried I found a Mac 6.1 being resold for a low enough price that it made more sense to do that. It came preloaded with Catalina as well as a bunch of other things. I loaded it up and everything else worked fine, some with a bit of tweaking but that was usually all completely obvious - I use this system as my primary recording studio system and I’ve experienced zero issues with using the interface I have in Logic Pro.

Problem:
I went to broadcast my Monday night live show tonight and Mixxx started giving me errors (this isn’t uncommon as I typically use a secondary interface for headphone output of mic out) and so I went in to fix things and I set everything as it should be set up. I hit OK and started getting ‘Error opening “Interface” Internal Port Audio error’. This happens whenever I change the interface to be either of the connected interfaces, or even when I set the main out or anything to be Loopback. I tried changing variables around and it just gave me the same error but with different “Interface” names.

The Mixxx boot-up error is “Mixx was configured without any output sound devices. Audio processing will be disabled without a configured output device.” - despite this, they ALL show up and are selectable in the dropdown menus in preferences. Typically when they are unavailable in Mixxx, they just don’t appear. Even hot swapping doesn’t work, in my experience, with Mixxx.

Usually I’m able to fix issues with most software myself, but for this I’ve found myself so frustrated and annoyingly without any solutions I have been able to find online through searching in the way I search… which I think is pretty typical?

Any assistance would be appreciated, my specs are:
macOS Catalina 10.15.5
Mac Pro (Late 2013)
2.7GHz 12-Core Intel Xeon E5
64GB 1866 MHz DDR3
Graphics AMD FirePro D700 6GB

My main audio interface is the UAD Apollo 8 Quad, and I like to connect a Focusrite Scarlett 2i2 as my secondary when I want to separate audio streams without going under my desk to swap cables around. Everything is up-to-date.

Please let me know if you need anything else. I’m not a Mac guy, by any means, I just grew into Logic - so I’m sure it’s possible what I’m missing might be blatantly obvious to someone.

Thank you!

Can you attach your mixxx.log file after you get this error? That may have more details about the error.

Attached here. I renamed the log file after the first error notice popped up on open, while the splash/loading window was still present.
mixxx-openerror.log (41.7 KB)

Unfortunately the log doesn’t provide a more useful error message. :confused: I see the audio interface you are using is a Thunderbolt interface, which is unusual but shouldn’t be a problem as long as the OS supports it. Does Mixxx work with your Focusrite Scarlett 2i2?

It doesn’t, also unfortunately. It seems to be an “everything” issue more than a specific or targeted interface or input.

So I guess the accessibility permissions aren’t set at all, and I have no idea how to add Mixxx to the microphone category… installation doesn’t attempt it itself either. Is it a known Catalina issue?

Edit: Ok so it’s in “Accessibility” and is checked, but it’s not under Microphone access permissions or anything else. Does this matter?

I should also mention that butt also shows the following error
PA: Format not supported: Internal PortAudio error

SOLVED:

After months of frustration and sometimes raging and breaking objects in my immediate surroundings, I believe I’ve figured it out.

Apparently this is a HUGE issue with PortAudio and many different interfaces and related software. Audacity is another piece of software which had an array of the same/similar issues: people upgrading to Catalina, or moving an existing MacOS account from a previous OS version to Catalina, would receive PortAudio errors and none of the interfaces or controllers would be clickable or even appear (for some).

I went down the rabbit hole for the 9th time, several… several beers in, 5am in the morning and came across some developer forum somewhere and they mentioned something about how they had gone in and deleted a bunch of random .plist files in Preferences and suddenly everything worked. They didn’t know which particular ones, at that point I didn’t give a shart.

Ultimately, deleting the below .plist files and then restarting seems to have fixed the issue for me. It’s likely just one of these that’s the culprit, but I’m hoping this post will help people with the same issue so they don’t have to go through the same level of pain.

com.apple.audio.AudioMIDISetup.plist
com.apple.audio.InfoHelper.plist
com.uaudio.uad_meter.plist
com.uaudio.uad.plist

THAT BEING SAID, I did think I had solved it by repairing permissions through Terminal weeks ago, it worked once or twice after that, and then reverted to the same garbage and permissions fixing would no longer work. At this point I tried opening Mixxx through terminal with the hope that it would allow me to set permissions a different way. It kind of did, but still didn’t work, however I got these errors:


Mac-Pro:~ mac_01$ /Applications/Mixxx.app/Contents/MacOS/Mixxx ; exit;
Warning [Main]: Empty filename passed to function
Warning [Main]: src/skin/legacyskinparser.cpp:2110 SKIN ERROR at skin:tool_bar.xml:344 : LegacySkinParser::setupConnections(): EmitOnPressAndRelease must not set false
Warning [Main]: src/skin/legacyskinparser.cpp:2110 SKIN ERROR at skin:skin_settings.xml:40 : LegacySkinParser::setupConnections(): EmitOnPressAndRelease must not set false
||PaMacCore (AUHAL)|| Failed to open AUHAL component.||PaMacCore (AUHAL)|| Error on line 1263: err=’-50’, msg=Unknown Error
Warning [Main]: Error opening stream: Internal PortAudio error
||PaMacCore (AUHAL)|| Failed to open AUHAL component.||PaMacCore (AUHAL)|| Error on line 1263: err=’-50’, msg=Unknown Error
Warning [Main]: Error opening stream: Internal PortAudio error


Shortly after this happened, it was decided my only course of action would be to try deleting .plist files and alas, we are here. For all I know it will all go to shit again and this post will have been completely useless… but I will repost here if that becomes the case.

1 Like

I had a similar issue with Sononym on macOS Catalina (10.15.7). At some point it stopped playing audio and displayed the error: “Audio failed to initialize” and in the audio configuration dialog it said “Failed to initialize default audio configuration: Internal PortAudio error”.

I wanted to try removing the plist files as suggested above. But I couldn’t even find them on my system.

After some more digging through the web, I found a suggestion to create a new user (which would be missing a lot of the audio stuff I had installed for my user) and try with that one. And what do you know: Sononym worked just fine.

Then I logged on with my regular user account again and removed everything from /Library/Audio/Plug-Ins/Components, /Library/Audio/Plug-Ins/VST and /Library/Audio/Plug-Ins/VST3. Started Sononym and it worked. So, I moved stuff back in batches and tried running the software every time until I had identified the culprit. In my case, it was HoRNetSongKeyMK3.component that didn’t get along with Sononym. Don’t know why yet but I’ll report it to the Sononym guys so they can follow up. In any case, this approach might help someone to solve similar issues.

Maybe this bug will be fixed by switching PortAudio to the newer CoreAudio API: https://github.com/PortAudio/portaudio/pull/356

Hello, I came here from many different places, I have been going through this problem fr 5 days now. It’s driving me insane. I can not find the .plist files you mention?
I wonder could you help please.
Many thanks

What is this, how do I get it?