Mic is clipping - popping

Hello,

I need help. I am having problems with Mixxx, out of nowhere every time I am talking on mi microphone, suddenly star popping or clipping, sounds like is interfering with something, and also it sounding interference.

We uninstall the program, installed again and the problem continues. Well I also thought that my 4 month old console was given up and I just spend another $200 on a console-mixer.

Can i get some much needed help please.

Hi,

What OS are you running. I have been having the same problem running on Windows 10 (and a couple of friends who use MIXXX also have the problem).

I downloaded and installed the latest version of MIXXX, and Windows 10 . It “appears” to be related to a Windows update. No idea which update caused it.

Somebody mentioned setting in “Settings”->“Sound”->“Advanced Settings”.

There is an “App Volume”. It helps some if you make sure the devices are the ones you want MIXXX to use. And I moved the Volume slider down from 100 and that also helped some. It is still pretty sensitive and easy to get popping if you talk too loud and over drive the mic.

I have tried different mics, both USB and Analog. All have the same problem.

Is there a solution for this issue? I had try everything there is???

If you are running Windows 10, there is a ‘recent’ update (I have no idea which one… sorry) that started this.

What helped for me is that I increased the Audio Buffer underp Preferences/Sound Hardware. It was at 23.2 ms, I increased it to 46.4 ms, and that seemed to clear up the popping/clipping.

Let me know if this helps your problem too please.

Here’s the thing…

I used Mixxx on Windows 10, and yes, I used a USB Mic. Clipping, popping sounds all over the place started happening as recently as last week. I increased the Audio Buffer in Preferences and the voice was delayed but still clipping and popping.

So, I remembered the official stance on USB with Mixxx: don’t use it. (Haven’t had an issue for 4 years. Figured if it works and isn’t supported, why not, right?) In the past, I was able to resolve by unplug/replug/Query Devices/reselect. Now, that doesn’t make a difference. Even a reboot, still pops.

Today, I removed all USB connections (except Keyboard and Mouse) then plugged in an analog headset (stereo/mic jacks, sound card inputs only, no power). The SAME popping sounds are happening. This lends me to think USB isn’t the cause anymore.

I’ll hop into Ubuntu 20.04 on the same machine and let you know if it’s consistent there.

Back from Ubuntu 20.04. On my machine anyway, it’s Windows specific. Hardware is fine both Sound Card and USB.

I am using
here is some info, MIXXX 2.2.0-rc

windows 10 home edition
2tb sata drive
256
16ram
and I got this popping issues whent talkinf on the mic
and cannot fixed it, this is a brand new computer

First, try using an up-to-date version of Mixxx (2.2.4). If that doesn’t resolve the issue, please post a Screenshot of the sound preferences in Mixxx.