Mixtrack Pro 3

Will be submitting a PR including Sample load soon!

You may follow progress here: github.com/mixxxdj/mixxx/pull/1180

Ejecting samples needs to be done a different way. Shift + Sample button is already mapped to play without sync, and I think I’d like to keep it that way.

Do you guys use the iCUT feature?

My right Jog wheel won’t scratch. When the wheel key is pressed it doesn’t do anything even when the song is not playing. When it is pressed it changes pitch. Is this happening to anyone else or am I just doing something wrong?

Will take a look at these and make sure they’re solved for Mixxx 2.1. The wiki page is a pretty good cheatsheet: mixxx.org/wiki/doku.php/num … rack_pro_3

I don’t have this issue. The fact that it affects only the right wheel may suggest a hardware issue?

I got it to work on Virtual DJ while i still had the trial version.

got an error message with the latest Steph script:

Uncaught exception at line 1393 in file /home/alex/.mixxx/controllers/Numark-Mixtrack-3-scripts.js: TypeError: Result of expression 'group' [undefined] is not an object.

any idea?

EAGERLY waiting for Mixxx 2.1… do you know more or less when it will be released? Many stuff to fix here.

A modified Mixtrack (Pro) 3 mapping was just merged with the master git branch making use of the new effects UI in Mixxx 2.1. The latest builds from the build server have it included (although it looks like 32 bit Windows builds are not working right now). For now, you’ll need to use the Deere skin to use the new effects controls and mapping (the other skins have not been updated yet). The wiki page has a description of changes in the mapping.

There were a few bugs like this that are fixed and now merged into the 2.1-alpha build.

Hi everyone,

First time posting here. I have downloaded the latest mappings and have been playing with it a bit. It’s pretty awesome and the folks here have done amazing work! There were a couple of small things though…

  1. I don’t like how the smartpfl works and does not let you use the pfl on both decks. I have disabled it in the .js file, but I’m still not able to use both, which is what I would like. I know I could use the knob to control pfl/main mix, but that does not work for me. Although I’m no programmer I have basic knowledge of programming and could compare a previous version of the .js file where I could enable both buttons with the new one, but I thought I would ask… I really miss this function.

  2. I played around with 4 decks a little, but soft takeover was not working for me. Whenever I would play with one of the faders its position would change right away, jumping to the new position (if I’m on deck one, put the fader all the way up, then switch to deck three, as soon as I move the fader it jumps to being all the way up), which is not how that’s supposed to work if I understand correctly. I’ll play with it again tonight and try again. Is anyone else having this issue or does the soft takeover seem to be working?

Again, great work on this mapping. I’m very pleased with it.

Which version of the mapping and which version of Mixxx are you using, DubmasterBluebear?

I am using Mixxx 2.0.0 and the latest version of the mapping/script downloaded from this forum, version 2.2.

I’m still having an issue with the right jog wheel always being in pitch change mode. I’ve tried reinstalling everything as well as editing the variable pitch change when wheel button isn’t pressed to false in the js file. I don’t think it is a hardware issue because I could use it to seek/scratch on virtual dj when I had the free trial. Anyone else having this issue?

Do you have that issue with the mapping included in recent 2.1 alpha builds?

Yeah I still have the same issue

Are you sure you’re using the updated mapping? I think you’ll need to pick Numark Mixtrack Pro 3 from the drop down menu in the Preferences again and click Apply. Changes in the new mapping are described on the wiki page.

I’ve updated the mapping and have tried reinstalling everything as well. It works with the left jog wheel, it is only the right jog while that is having the issue.

Hi everyone,

I have a “Newbie-Question”: I want to use my “Numark MixTrack Pro 3” with “Mixxx 2.0.0” and “Ubuntu Linux 16.04 LTS”.

After the Download of “Numark-Mixtrack-3-scripts-v2.2” I extracted the files in “.mixxx/controllers”.
Under “preferences” I choose the “MixTrack Pro Midi 1” and loaded “Numark Mixtrack (Pro) 3”.
When I click on “Sound-Hardware” I choosed for the Master “Mixtrack Pro 3: USB Audio - Channel 1-2” and for the headphones “Mixtrack Pro 3: USB Audio - Channel 3-4”.

Now the 2 problems:

  • I can’t activate both decks on the same time for my headphone on the Mixtrack - I can only switch. But in Mixxx I can activate them both.
  • Auto Sync seems not to work?!

Thanks in advance!

This is a feature implemented by the mapping for convenience. If you’d like to disable it, you can set the smartPFL option to false at the top of the script file in ~/.mixxx/controllers.

What do you mean? What happens when you try to use it?

There is no “Auto Sync”-Option on the controller, right?
Of course I try and I do Beatmatching with the wheels; but it would be nice to have an option there.