Mixtrack Pro 3

I’ve updated the mapping and have tried reinstalling everything as well. It works with the left jog wheel, it is only the right jog while that is having the issue.

Hi everyone,

I have a “Newbie-Question”: I want to use my “Numark MixTrack Pro 3” with “Mixxx 2.0.0” and “Ubuntu Linux 16.04 LTS”.

After the Download of “Numark-Mixtrack-3-scripts-v2.2” I extracted the files in “.mixxx/controllers”.
Under “preferences” I choose the “MixTrack Pro Midi 1” and loaded “Numark Mixtrack (Pro) 3”.
When I click on “Sound-Hardware” I choosed for the Master “Mixtrack Pro 3: USB Audio - Channel 1-2” and for the headphones “Mixtrack Pro 3: USB Audio - Channel 3-4”.

Now the 2 problems:

  • I can’t activate both decks on the same time for my headphone on the Mixtrack - I can only switch. But in Mixxx I can activate them both.
  • Auto Sync seems not to work?!

Thanks in advance!

This is a feature implemented by the mapping for convenience. If you’d like to disable it, you can set the smartPFL option to false at the top of the script file in ~/.mixxx/controllers.

What do you mean? What happens when you try to use it?

There is no “Auto Sync”-Option on the controller, right?
Of course I try and I do Beatmatching with the wheels; but it would be nice to have an option there.

There are sync buttons above the cue and play buttons…

I know. But I have only the effect that both tracks have the same BPM after pressing this button - But no Auto-Sync.

Can you help me please?
I downloaded the map and placed it in C / program (x68) / mixx / controllers
Hardware collego, apro mixxx and tells me this:

One or more MixxxControls specified in the outputs section of the loaded preset were invalid.

Some LEDs or other feedback may not work correctly.

  • Check to see that the MixxxControl names are spelled correctly in the mapping file (.xml)
  • Make sure the MixxxControls in question actually exist. Visit this wiki page for a complete list: mixxx.org/wiki/doku.php/mixxxcontrols

MIDI output message 0x90 0x64 has invalid MixxxControl [Channel2], flanger
MIDI output message 0x90 0x63 has invalid MixxxControl [Channel1], flanger

Where did you download the mapping? The flanger Controls are very old and were removed in Mixxx 2.0 when the effects framework was introduced.

New link please…
I’m new to this software

In fact the link on the page is old

https://mixxx.org/wiki/doku.php/numark_mixtrack_pro_3

[url]https://mixxx.discourse.group/t/mixtrack-pro-3/15165/234]

That mapping does not use the old Flanger controls. Are you sure that’s the mapping you loaded? Try removing everything in your user controller mapping folder and downloading the mapping again.

images/icons/smile/mrgreen.gif

OK thanks!!
You have to have patience I started with technics sl1200 in 1985!
I m expert dj but not so much about software …
I had Hercules with virtualdj o djjudjed seems to me …
Now this Numark PRO III with serato intro good for live but lacking important functions.
Mixxx I like it! I have correctly reinstalled the 68 bit wnd version and configured the mapping and after a while almost everything works!! :mrgreen:
Unfortunately I do not recognize the sound card of the controller on “audio hardware” I only see ASIO4ALL v2
I can not crap the effects fx do not know how it is done.
These are my first findings, thank you in advance.

Try selecting WASAPI as your Sound API.

HI people,

I’m using since … 2/3 weeks the master daily builds of Mixxx 2.1 … and the progress is significant, well done.
Yes, it’s taking forever for this release and still it’s not 100% perfect, but almost there, in other words: it’s usable as much as v. 2.0 - if not better.
Problem is sometimes Mixxx still forgetting/screwing up jack and controller settings.
Other problem are the effects and the EQs that don’t look like working in realtime, so the feedback with the output is a bit weird.
Mixtrakck Pro 3 midi bindigs paired with Deere Skin is GREAT, and I wouldn’t change anything.

Now I have a question, maybe in case I will open another Thread in this forum:
I’m routing Deck 1 and 2 to two audio buses in Ardour to give some compressions and effects… it’s just that the faders and the crossfader are not working anymore.
I guess Ardour is receiving a pre-fader output from Mixxx, but I don’t understand why it should work like this, I mean, in other words: why is it losing the fader functionaliy?
How to correct this problem?
A - map Mixtrack L/R faders in Ardour to control the L/R Deck faders if possible at all
B - map Mixtrack L/R faders in Mixxx as L/R gain
C - correct the behavior (upstream?) so Mixxx is sending post-fader signal to a DAW
D- suggestions?

thank you guys!

None of those issues have to do with the Mixtrack Pro 3 specifically, so please open a new thread to discuss them to avoid cluttering this thread.

done https://mixxx.discourse.group/t/2-decks-audio-routing-to-ardour-problem-controller/16754/1

Hey everyone. Just downloaded Mixxx 2.1 from the website to try it out. I’m still having the issue, even with smartpfl disabled, of not being able to have both decks go through on the headphones. As soon as I toggle one deck, the other one toggles off. And as I said, smartpfl is disabled. Is there any other thing in the config file I need to disable?
Thanks!

Steph (and anyone who might know),
i am trying to tweak your script in a way that the beat knobs (left.ch1.0xB1.0x13 and right.ch2.0xB2.0x13), change the pregain for each channel instead of the effects, but it seems such a task is well over my abilities…
Is there an easy or quick way to do that or would it require extended modifications/re-writing?

Hi All,

I made a small change to the Mixtrack 3 script. It introduces a way to control the channel gain using the Shift+Filter knobs. The script uses the default behavior by default (Shift+Filter controls FX4). To enable gain control please change var ShiftFilterFX4 to false. Seems to work fine with mixxx 2.0.
Numark-Mixtrack-3-scripts.zip (18 KB)

Hey ntmusic,
i will try it…