Mixxx 2.1.2 running much slower than 2.1.1

Hi everyone.

I just downloaded Mixxx 2.1.2 today and installed it with seemingly no issues, but when I opened the software and started playing songs with it, the interface (particularly the waveform display) was incredibly laggy, and pressing different buttons like the hotcue triggers had a lot of delay compared to the 2.1.1 version.

I uninstalled 2.1.2 and reinstalled 2.1.1, and everything ran smoothly as it used to. I then uninstalled 2.1.1 and reinstalled 2.1.2 again, only to encounter the same laggy issue.

This wouldn’t be too much of a problem for me if it weren’t for the fact that I really want to take advantage of using hotcues with quantizing disabled, which is not available in 2.1.1, and I do not want to go back to using Mixxx 2.0.X.

Is anyone else experiencing this issue? If so, any help/advice would be greatly appreciated.

EDIT: OK, so after some accidental resizing I figured out that the interface gets more and more laggy the larger I make the window, and fullscreen provides the most issues. However, running Mixxx in it’s smallest size runs smoothly. Not sure why this is, but if anyone could provide me with a solution I would greatly appreciate it.

i cant say i know of a way to fix this issue but i can say i had the same issue as you, and it forced me to go back to the older version since a laggy and sluggish mixxx isnt usable, i really hope they can roll out a hotfix for this soon.

Does this happen with every skin?

Please report you windows version and your API you are using.
It might be a build issue.
Can you please try this build:
ci.appveyor.com/api/buildjobs/n … se-x64.exe
Or this
ci.appveyor.com/api/buildjobs/9 … se-x86.exe
And report the errors here?

Does it make a difference if you enable or disable the preview coloum in the library?

I just tried resizing the window with all the other skins, and yeah it seems to be the same thing with all of them. No idea why

Are you able to identify a build that introduced the issue from this list?
downloads.mixxx.org/builds/2.1/release/

No, but it does make a difference when I enable/disable the effect racks and sampler decks, which leads me to believe that the library is what is causing the issue. At it’s smallest window size, there wasn’t any room for the library to show, but as soon as I disabled a couple of decks and the library was more visible, the lag started up again and pretty much makes the program useless for any live situation.

The issue started from version 2.1.2 onwards. Any version 2.1.1 or earlier works fine.

Both builds still have the exact same problem. I’m running Windows 10 on a 64 bit HP laptop

I don’t get lagging on Ubuntu but I checked CPU usage using htop and 2.1.2 appears to use 140-150% of the CPU of 2.1.0! So I think there may be a deeper problem that just Windows and GUI laggyness…

Maybe something is wrong with your hardware… I’m using Mixxx since 2011 with no issue until latest
version .

My equipment specs :

Sony Vaio VPC Series
Windows 7 64 Bit Home Premium
Intel Pentium B950 2.1Ghz
Intel HD Graphics
8Gb Ram
Numark Mixtrack Platinum

Make sure that you have clean install of genuine windows with all MS updates and disable services that you don’t need to.also optimize and set system to high performance plan.

Thanks, Mixxx Team for this big great Music Software.

I very much doubt that it is a problem with my hardware. All the settings I use are the same with 2.1.2 as they are with 2.1.1, and I experienced absolutely zero issues with earlier versions of Mixxx. (I also use the Numark Mixtrack Platinum :smiley: )

Can you identify the lowest
2.1.2-pre-2.1-git number which is effected?
From:
downloads.mixxx.org/builds/2.1/release/
?

I can confirm the problem.

git6746 was OK
git6748 was the first build showing the problem.

I can confirm the artifact from PR#1787 doesn’t have the problem anymore.

So does that mean they’ve fixed the issue now? Will it be solved if I download the main installer again?

The updated version fixed this issue

you can download Mixxx 2.1.3 which fix the issue from mixxx.org/download/

On the OS Linux Mint 62 bit works with large brakes.

b Core™ i5-2500K CPU
Board Vendor: ASUSTeK COMPUTER INC.
Bios Version: 1404
Memory 8 gb.[/b]