Mixxx 2.2.2 always hangs after the 2nd start

Mixxx hängt nach dem 2. Start immer

Ich hab Mix installiert, alls Soundquellen eingerichtet und meine Library einlesen lassen.
dann ein Test laufen lassen = Problemlos.
Nach einem nochmaligen Start, öffnet sich mix, die Musik wird reingeladen. Dann geht nichts mehr. Es kommt nur noch die Meldung “Das Programm reagiert nicht mehr…”

Erst wenn ich die mixxx.cfg lösche, kann ich Mixxx wieder nutzen, nachdem ich wieder alle Einstellungen vorgenommen habe.

Das Logfile findet Ihr hier: pastebin.com/e4buKTvR


Mixxx always hangs after the 2nd start

I installed Mix, set up all sound sources and had my library read in.
then run a test = problem-free.
After a second start, mix opens, the music is loaded. Then nothing works. There is only the message “The program is not responding …”

Only when I delete the mixxx.cfg, I can use Mixxx again, after I have made all the settings again.

You can find the logfile here: pastebin.com/e4buKTvR

Any Ideas?

Hi,
I have downgrade to 2.1.8, this Version will running fine…

The posted log looks like it is from a working run.
Please post one from a crash.
You may also try to start Mixxx with the
–safeMode start option. Does this make a difference?

Sorry for answering so late …

The problem does not occur in -safemode.

the following log file without -safemode:

Info [Main]: SoundSourceProxy - Loading SoundSource plugins "C:/Program Files/Mixxx/plugins/soundsource"
Info [Main]: SoundSourcePluginLibrary - Dynamically loaded plugin library "C:/Program Files/Mixxx/plugins/soundsource/soundsourcemediafoundation.dll"
Warning [Main]: SoundSourcePluginLibrary - Failed to dynamically load plugin library "C:/Program Files/Mixxx/plugins/soundsource/soundsourcemediafoundation.exp" : "Cannot load library C:\\Program Files\\Mixxx\\plugins\\soundsource\\soundsourcemediafoundation.exp: Unknown error 0x000000c1."
Warning [Main]: SoundSourceProxy - Failed to load SoundSource plugin "C:/Program Files/Mixxx/plugins/soundsource/soundsourcemediafoundation.exp"
Warning [Main]: SoundSourcePluginLibrary - Failed to dynamically load plugin library "C:/Program Files/Mixxx/plugins/soundsource/soundsourcemediafoundation.lib" : "Cannot load library C:\\Program Files\\Mixxx\\plugins\\soundsource\\soundsourcemediafoundation.lib: Unknown error 0x000000c1."
Warning [Main]: SoundSourceProxy - Failed to load SoundSource plugin "C:/Program Files/Mixxx/plugins/soundsource/soundsourcemediafoundation.lib"
Warning [Main]: SoundSourcePluginLibrary - Failed to dynamically load plugin library "C:/Program Files/Mixxx/plugins/soundsource/soundsourcemediafoundation.pdb" : "Cannot load library C:\\Program Files\\Mixxx\\plugins\\soundsource\\soundsourcemediafoundation.pdb: Unknown error 0x000000c1."
Warning [Main]: SoundSourceProxy - Failed to load SoundSource plugin "C:/Program Files/Mixxx/plugins/soundsource/soundsourcemediafoundation.pdb"
Debug [Main]: "Mixxx" "2.2.3" "(git 2.2 r6750; built on: Dec  1 2019 @ 18:22:20; flags: asan=0 asmlib=0 battery=1 buildtime=1 bulk=0 color=0 coreaudio=0 faad=0 ffmpeg=0 hid=1 hss1394=1 ipod=0 lilv=0 localecompare=1 macappstore=0 mad=1 mediafoundation=1 modplug=0 opengles=0 optimize=portable opus=1 perftools=0 perftools_profiler=0 profiling=0 qt_sqlite_plugin=0 qtkeychain=0 shoutcast=1 test=1 tsan=0 ubsan=0 vamp=1 verbose=0 vinylcontrol=1 wv=0)" is starting...
Debug [Main]: Compile time library versions:
Debug [Main]: Qt: 5.11.1
Debug [Main]: libshout: 2.4.1
Debug [Main]: PortAudio: 1246720 PortAudio V19.6.0-devel, revision 396fe4b6699ae929d3a685b3ef8a7e97396139a4
Debug [Main]: RubberBand: 1.8.1
Debug [Main]: SoundTouch: 2.0.0
Debug [Main]: TagLib: 1.11.1
Debug [Main]: ChromaPrint: 1.3.1
Debug [Main]: Vorbis: Xiph.Org libVorbis 1.3.5
Debug [Main]: libsndfile: libsndfile-1.0.26
Debug [Main]: FLAC: 1.3.1
Debug [Main]: QDesktopServices::storageLocation(HomeLocation): "C:/Users/micha"
Debug [Main]: QDesktopServices::storageLocation(DataLocation): "C:/Users/micha/AppData/Local/Mixxx"
Debug [Main]: QCoreApplication::applicationDirPath() "C:/Program Files/Mixxx"
Debug [Main]: Loading resources from  "C:/Program Files/Mixxx/"
Debug [Main]: Configuration file is at the current version 2.2.3
Info [Main]: BroadcastSettings - Found 1 profile(s)
Debug [Main]: Loading resources from  "C:/Program Files/Mixxx/"
Debug [Main]: Loading resources from  "C:/Program Files/Mixxx/"
Debug [Main]: Loading translations for locale "de_DE" from translations folder "C:/Program Files/Mixxx/translations/" : success
Debug [Main]: "Error: Unable to import console: no such extension"
Debug [Main]: "Error: Unable to import svg: no such extension"
Debug [Main]: Loading resources from  "C:/Program Files/Mixxx/"
Debug [Main]: Compressor attack per frame:  0.000356768 decay per frame:  3.56768e-05
Debug [Main]: EngineNetworkStream - addWorker: worker added
Debug [Main]: EngineNetworkStream - worker slots used: "1 out of 16"
Debug [Main]: BroadcastManager - addConnection: created connection for profile "Lupopa's Sound of Dreams"
Debug [Main]: WARNING: AudioInput already registered!
Debug [Main]: WARNING: AudioInput already registered!
Debug [Main]: WARNING: AudioInput already registered!
Debug [Main]: WARNING: AudioInput already registered!
Info [Main]: DbConnection - Available drivers for database connections: ("QSQLITE")
Info [Main]: DbConnectionPool - Cloned thread-local database connection "MIXXX-1" QSqlDatabase(driver="QSQLITE", database="C:/Users/micha/AppData/Local/Mixxx/mixxxdb.sqlite", host="localhost", port=-1, user="mixxx", open=true)
Info [Main]: MixxxMainWindow - Connecting to database
Info [Main]: MixxxMainWindow - Initializing or upgrading database schema
Info [Main]: SchemaManager - Database schema is up-to-date at version 28
Debug [Main]: LibraryScanner - Starting thread
Info [Main]: Library - Connecting database
Debug [LibraryScanner 1]: LibraryScanner - Entering thread
Info [LibraryScanner 1]: DbConnectionPool - Cloned thread-local database connection "MIXXX-2" QSqlDatabase(driver="QSQLITE", database="C:/Users/micha/AppData/Local/Mixxx/mixxxdb.sqlite", host="localhost", port=-1, user="mixxx", open=true)
Info [LibraryScanner 1]: LibraryScanner - Cleaning up database...
Info [LibraryScanner 1]: LibraryScanner - Finished database cleanup: 8 ms
Debug [LibraryScanner 1]: LibraryScanner - Event loop starting
Debug [Main]: Committing transaction on "MIXXX-1" result: true
Debug [Main]: CrateFeature::rebuildChildModel() -1
Debug [Main]: Default quick links: ("C:/Users/micha/Music/MIXXX/", "C:/Users/micha/Music/", "C:/Users/micha/Downloads/", "C:/Users/micha/OneDrive/Desktop/", "C:/Users/micha/OneDrive/Dokumente/")
Debug [Main]: Appending Quick Link:  "MIXXX" --- "C:/Users/micha/Music/MIXXX/"
Debug [Main]: Appending Quick Link:  "Music" --- "C:/Users/micha/Music/"
Debug [Main]: Appending Quick Link:  "Downloads" --- "C:/Users/micha/Downloads/"
Debug [Main]: Appending Quick Link:  "Desktop" --- "C:/Users/micha/OneDrive/Desktop/"
Debug [Main]: Appending Quick Link:  "Dokumente" --- "C:/Users/micha/OneDrive/Dokumente/"
Debug [Main]: Committing transaction on "MIXXX-1" result: true
Debug [Main]: Traktor Library Location=[ "C:/Users/micha/collection.nml" ]
Debug [Main]: Checking for access to user's library directories:
Debug [Main]: Checking for access to "C:/Users/micha/Music/MIXXX" : true
Debug [AnalyzerQueue 1]: AnalyzerQueue - Entering thread
Info [AnalyzerQueue 1]: DbConnectionPool - Cloned thread-local database connection "MIXXX-3" QSqlDatabase(driver="QSQLITE", database="C:/Users/micha/AppData/Local/Mixxx/mixxxdb.sqlite", host="localhost", port=-1, user="mixxx", open=true)
Debug [Main]: Creating ControllerManager
Debug [Controller]: ControllerManager:slotInitialize
Debug [Main]: Set root GL Context widget valid: QGLWidget(0x195e3e4d690) true
Debug [Main]: Created root GL Context valid: 0x195e3e96290 true
Debug [Main]: Root GL Context format:
Debug [Main]: Double Buffering: true
Debug [Main]: Swap interval: 1
Debug [Main]: Depth buffer: true
Debug [Main]: Direct rendering: true
Debug [Main]: Has overlay: false
Debug [Main]: RGBA: true
Debug [Main]: Sample buffers: false
Debug [Main]: Samples: -1
Debug [Main]: Stencil buffers: true
Debug [Main]: Stereo: false
Debug [Main]: "openGLVersionFlags 0xff07f" "4.6.0 NVIDIA 456.71" "NVIDIA Corporation" "GeForce GTX 1070/PCIe/SSE2"
Debug [Main]: screensaver inhibited
Debug [Main]: ControllerManager::getControllerList
Info [Main]: VampPluginAdapter - Current VAMP_PATH is: ""
Info [Main]: VampPluginAdapter - Setting VAMP_PATH to: "C:\\Program Files\\Mixxx\\plugins\\vamp"
Debug [Main]: VampPluginLoader::listPlugins() returned 4 plugins
Debug [Main]: Plugin output displayname: "mixxxbpmdetection:0" "SoundTouch BPM Detector (Legacy)"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:0" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:1" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:2" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:3" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-keydetector:0" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-keydetector:1" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-keydetector:2" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-keydetector:3" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-tempotracker:0" "Tempo and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-tempotracker:1" "Tempo and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-tempotracker:2" "Tempo and Beat Tracker"
Debug [Main]: VampPluginLoader::listPlugins() returned 4 plugins
Debug [Main]: Plugin output displayname: "mixxxbpmdetection:0" "SoundTouch BPM Detector (Legacy)"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:0" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:1" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:2" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:3" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-keydetector:0" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-keydetector:1" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-keydetector:2" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-keydetector:3" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-tempotracker:0" "Tempo and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-tempotracker:1" "Tempo and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-tempotracker:2" "Tempo and Beat Tracker"
Debug [Main]: DlgPrefKey::loadSettings
Debug [Main]: Key plugin ID: "qm-keydetector:2"
Debug [Main]: LegacySkinParser loading skin: "C:/Program Files/Mixxx/skins/LateNight"
Debug [Main]: "Error: Unable to import console: no such extension"
Debug [Main]: "Error: Unable to import svg: no such extension"
Debug [Main]: Skin is a >=1.12.0 style skin.
Debug [Main]: Created QGLWidget. Context Valid: true Sharing: true
Debug [Main]: GLWaveformRendererSignalShader::loadShaders
Debug [Main]: WaveformWidgetFactory::setWaveformWidget - waveform widget added in factory, index 0
Debug [Main]: Created QGLWidget. Context Valid: true Sharing: true
Debug [Main]: GLWaveformRendererSignalShader::loadShaders
Debug [Main]: WaveformWidgetFactory::setWaveformWidget - waveform widget added in factory, index 1
Debug [Main]: Created QGLWidget. Context Valid: true Sharing: true
Debug [Main]: GLWaveformRendererSignalShader::loadShaders
Debug [Main]: WaveformWidgetFactory::setWaveformWidget - waveform widget added in factory, index 2
Debug [Main]: Created QGLWidget. Context Valid: true Sharing: true
Debug [Main]: GLWaveformRendererSignalShader::loadShaders
Debug [Main]: WaveformWidgetFactory::setWaveformWidget - waveform widget added in factory, index 3
Debug [Main]: WSearchLineEdit - Background color: QColor(ARGB 1, 1, 1, 1)
Debug [Main]: WSearchLineEdit - Foreground color: QColor(ARGB 1, 0, 0, 0)
Debug [Main]: WTrackTableView::loadTrackModel() HiddenTableModel(0x195edd32940)
Debug [Main]: WTrackTableView::loadTrackModel() MissingTableModel(0x195edd33200)
Debug [Main]: WTrackTableView::loadTrackModel() PlaylistTableModel(0x195e3c5d540)
Debug [Main]: Recordings folder set to "C:/Program Files/Mixxx"
Debug [Main]: WTrackTableView::loadTrackModel() QSortFilterProxyModel(0x195f0137c68)
Debug [BrowseThread]: Append last  0
Debug [Main]: WTrackTableView::loadTrackModel() AnalysisLibraryTableModel(0x195edd32e80)
Debug [Main]: BaseTrackCache(0x195dc349320) updateIndexWithQuery took 8 ms
Debug [Controller]: Extension .midi.xml total 110 presets
Debug [Controller]: Extension .hid.xml total 23 presets
Debug [Controller]: Extension .bulk.xml total 1 presets
Debug [Main]: AnalysisLibraryTableModel(0x195edd32e80) select() took 26 ms 1399
Debug [Main]: AnalysisLibraryTableModel(0x195edd32e80) select() took 12 ms 1399
Debug [Main]: DlgAnalysis(0x195db5d5e00, name="DlgAnalysis") analysisActive false
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: Unknown property qpoperty-layoutAlignment
Debug [Main]: Unknown property qpoperty-layoutAlignment
Debug [Main]: MixxxLibraryFeature::activate()
Debug [Main]: WTrackTableView::loadTrackModel() LibraryTableModel(0x195dd6a3420)
Debug [Main]: LibraryTableModel(0x195dd6a3420) select() took 12 ms 1399
Debug [Main]: trying to restore position
Debug [Controller]: ControllerManager: Setting up devices
Debug [Controller]: Scanning PortMIDI devices:
Debug [Controller]:  Found output device # 0 Microsoft MIDI Mapper
Debug [Controller]:  Found output device # 1 Microsoft GS Wavetable Synth
Debug [Controller]: Scanning HSS1394 devices:
Debug [Controller]:    Nodes detected: 0
Debug [Controller]: Scanning HID devices:
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler1]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler2]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler3]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler4]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler5]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler6]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler7]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler8]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler9]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler10]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler11]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler12]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler13]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler14]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler15]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler16]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler17]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler18]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler19]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler20]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler21]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler22]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler23]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler24]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler25]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler26]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler27]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler28]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler29]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler30]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler31]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler32]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler33]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler34]"
Debug [Controller]: Found "Logitech" "USB Receiver" "r4625" S/N "" "Interface 2"
Debug [Controller]: Found "Logitech" "USB Receiver" "r4625" S/N "" "Interface 1"
Debug [Controller]: Found "Logitech" "USB Receiver" "r4625" S/N "" "Interface 1"

Greetings Lupo

now in -safeMode same Problem:

Info [Main]: SoundSourceProxy - Loading SoundSource plugins "C:/Program Files/Mixxx/plugins/soundsource"
Info [Main]: SoundSourcePluginLibrary - Dynamically loaded plugin library "C:/Program Files/Mixxx/plugins/soundsource/soundsourcemediafoundation.dll"
Warning [Main]: SoundSourcePluginLibrary - Failed to dynamically load plugin library "C:/Program Files/Mixxx/plugins/soundsource/soundsourcemediafoundation.exp" : "Cannot load library C:\\Program Files\\Mixxx\\plugins\\soundsource\\soundsourcemediafoundation.exp: Unknown error 0x000000c1."
Warning [Main]: SoundSourceProxy - Failed to load SoundSource plugin "C:/Program Files/Mixxx/plugins/soundsource/soundsourcemediafoundation.exp"
Warning [Main]: SoundSourcePluginLibrary - Failed to dynamically load plugin library "C:/Program Files/Mixxx/plugins/soundsource/soundsourcemediafoundation.lib" : "Cannot load library C:\\Program Files\\Mixxx\\plugins\\soundsource\\soundsourcemediafoundation.lib: Unknown error 0x000000c1."
Warning [Main]: SoundSourceProxy - Failed to load SoundSource plugin "C:/Program Files/Mixxx/plugins/soundsource/soundsourcemediafoundation.lib"
Warning [Main]: SoundSourcePluginLibrary - Failed to dynamically load plugin library "C:/Program Files/Mixxx/plugins/soundsource/soundsourcemediafoundation.pdb" : "Cannot load library C:\\Program Files\\Mixxx\\plugins\\soundsource\\soundsourcemediafoundation.pdb: Unknown error 0x000000c1."
Warning [Main]: SoundSourceProxy - Failed to load SoundSource plugin "C:/Program Files/Mixxx/plugins/soundsource/soundsourcemediafoundation.pdb"
Debug [Main]: "Mixxx" "2.2.3" "(git 2.2 r6750; built on: Dec  1 2019 @ 18:22:20; flags: asan=0 asmlib=0 battery=1 buildtime=1 bulk=0 color=0 coreaudio=0 faad=0 ffmpeg=0 hid=1 hss1394=1 ipod=0 lilv=0 localecompare=1 macappstore=0 mad=1 mediafoundation=1 modplug=0 opengles=0 optimize=portable opus=1 perftools=0 perftools_profiler=0 profiling=0 qt_sqlite_plugin=0 qtkeychain=0 shoutcast=1 test=1 tsan=0 ubsan=0 vamp=1 verbose=0 vinylcontrol=1 wv=0)" is starting...
Debug [Main]: Compile time library versions:
Debug [Main]: Qt: 5.11.1
Debug [Main]: libshout: 2.4.1
Debug [Main]: PortAudio: 1246720 PortAudio V19.6.0-devel, revision 396fe4b6699ae929d3a685b3ef8a7e97396139a4
Debug [Main]: RubberBand: 1.8.1
Debug [Main]: SoundTouch: 2.0.0
Debug [Main]: TagLib: 1.11.1
Debug [Main]: ChromaPrint: 1.3.1
Debug [Main]: Vorbis: Xiph.Org libVorbis 1.3.5
Debug [Main]: libsndfile: libsndfile-1.0.26
Debug [Main]: FLAC: 1.3.1
Debug [Main]: QDesktopServices::storageLocation(HomeLocation): "C:/Users/micha"
Debug [Main]: QDesktopServices::storageLocation(DataLocation): "C:/Users/micha/AppData/Local/Mixxx"
Debug [Main]: QCoreApplication::applicationDirPath() "C:/Program Files/Mixxx"
Debug [Main]: Loading resources from  "C:/Program Files/Mixxx/"
Debug [Main]: Configuration file is at the current version 2.2.3
Info [Main]: BroadcastSettings - Found 1 profile(s)
Debug [Main]: Loading resources from  "C:/Program Files/Mixxx/"
Debug [Main]: Loading resources from  "C:/Program Files/Mixxx/"
Debug [Main]: Loading translations for locale "de_DE" from translations folder "C:/Program Files/Mixxx/translations/" : success
Debug [Main]: "Error: Unable to import console: no such extension"
Debug [Main]: "Error: Unable to import svg: no such extension"
Debug [Main]: Loading resources from  "C:/Program Files/Mixxx/"
Debug [Main]: Compressor attack per frame:  0.000356768 decay per frame:  3.56768e-05
Debug [Main]: EngineNetworkStream - addWorker: worker added
Debug [Main]: EngineNetworkStream - worker slots used: "1 out of 16"
Debug [Main]: BroadcastManager - addConnection: created connection for profile "Lupopa's Sound of Dreams"
Debug [Main]: WARNING: AudioInput already registered!
Debug [Main]: WARNING: AudioInput already registered!
Debug [Main]: WARNING: AudioInput already registered!
Debug [Main]: WARNING: AudioInput already registered!
Info [Main]: DbConnection - Available drivers for database connections: ("QSQLITE")
Info [Main]: DbConnectionPool - Cloned thread-local database connection "MIXXX-1" QSqlDatabase(driver="QSQLITE", database="C:/Users/micha/AppData/Local/Mixxx/mixxxdb.sqlite", host="localhost", port=-1, user="mixxx", open=true)
Info [Main]: MixxxMainWindow - Connecting to database
Info [Main]: MixxxMainWindow - Initializing or upgrading database schema
Info [Main]: SchemaManager - Database schema is up-to-date at version 28
Debug [Main]: LibraryScanner - Starting thread
Info [Main]: Library - Connecting database
Debug [LibraryScanner 1]: LibraryScanner - Entering thread
Info [LibraryScanner 1]: DbConnectionPool - Cloned thread-local database connection "MIXXX-2" QSqlDatabase(driver="QSQLITE", database="C:/Users/micha/AppData/Local/Mixxx/mixxxdb.sqlite", host="localhost", port=-1, user="mixxx", open=true)
Info [LibraryScanner 1]: LibraryScanner - Cleaning up database...
Info [LibraryScanner 1]: LibraryScanner - Finished database cleanup: 1 ms
Debug [LibraryScanner 1]: LibraryScanner - Event loop starting
Debug [Main]: Committing transaction on "MIXXX-1" result: true
Debug [Main]: CrateFeature::rebuildChildModel() -1
Debug [Main]: Default quick links: ("C:/Users/micha/Music/MIXXX/", "C:/Users/micha/Music/", "C:/Users/micha/Downloads/", "C:/Users/micha/OneDrive/Desktop/", "C:/Users/micha/OneDrive/Dokumente/")
Debug [Main]: Appending Quick Link:  "MIXXX" --- "C:/Users/micha/Music/MIXXX/"
Debug [Main]: Appending Quick Link:  "Music" --- "C:/Users/micha/Music/"
Debug [Main]: Appending Quick Link:  "Downloads" --- "C:/Users/micha/Downloads/"
Debug [Main]: Appending Quick Link:  "Desktop" --- "C:/Users/micha/OneDrive/Desktop/"
Debug [Main]: Appending Quick Link:  "Dokumente" --- "C:/Users/micha/OneDrive/Dokumente/"
Debug [Main]: Committing transaction on "MIXXX-1" result: true
Debug [Main]: Traktor Library Location=[ "C:/Users/micha/collection.nml" ]
Debug [Main]: Checking for access to user's library directories:
Debug [Main]: Checking for access to "C:/Users/micha/Music/MIXXX" : true
Debug [AnalyzerQueue 1]: AnalyzerQueue - Entering thread
Debug [Main]: Creating ControllerManager
Info [AnalyzerQueue 1]: DbConnectionPool - Cloned thread-local database connection "MIXXX-3" QSqlDatabase(driver="QSQLITE", database="C:/Users/micha/AppData/Local/Mixxx/mixxxdb.sqlite", host="localhost", port=-1, user="mixxx", open=true)
Debug [Controller]: ControllerManager:slotInitialize
Debug [Controller]: Extension .midi.xml total 110 presets
Debug [Controller]: Extension .hid.xml total 23 presets
Debug [Controller]: Extension .bulk.xml total 1 presets
Debug [Main]: Set root GL Context widget valid: QGLWidget(0x2c72504d990) true
Debug [Main]: Created root GL Context valid: 0x2c72561e000 true
Debug [Main]: Root GL Context format:
Debug [Main]: Double Buffering: true
Debug [Main]: Swap interval: 1
Debug [Main]: Depth buffer: true
Debug [Main]: Direct rendering: true
Debug [Main]: Has overlay: false
Debug [Main]: RGBA: true
Debug [Main]: Sample buffers: false
Debug [Main]: Samples: -1
Debug [Main]: Stencil buffers: true
Debug [Main]: Stereo: false
Debug [Main]: "openGLVersionFlags 0xff07f" "4.6.0 NVIDIA 456.71" "NVIDIA Corporation" "GeForce GTX 1070/PCIe/SSE2"
Debug [Main]: screensaver inhibited
Debug [Main]: ControllerManager::getControllerList
Info [Main]: VampPluginAdapter - Current VAMP_PATH is: ""
Info [Main]: VampPluginAdapter - Setting VAMP_PATH to: "C:\\Program Files\\Mixxx\\plugins\\vamp"
Debug [Main]: VampPluginLoader::listPlugins() returned 4 plugins
Debug [Main]: Plugin output displayname: "mixxxbpmdetection:0" "SoundTouch BPM Detector (Legacy)"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:0" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:1" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:2" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:3" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-keydetector:0" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-keydetector:1" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-keydetector:2" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-keydetector:3" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-tempotracker:0" "Tempo and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-tempotracker:1" "Tempo and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-tempotracker:2" "Tempo and Beat Tracker"
Debug [Main]: VampPluginLoader::listPlugins() returned 4 plugins
Debug [Main]: Plugin output displayname: "mixxxbpmdetection:0" "SoundTouch BPM Detector (Legacy)"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:0" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:1" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:2" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-barbeattracker:3" "Bar and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-keydetector:0" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-keydetector:1" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-keydetector:2" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-keydetector:3" "Key Detector"
Debug [Main]: Plugin output displayname: "qm-tempotracker:0" "Tempo and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-tempotracker:1" "Tempo and Beat Tracker"
Debug [Main]: Plugin output displayname: "qm-tempotracker:2" "Tempo and Beat Tracker"
Debug [Main]: DlgPrefKey::loadSettings
Debug [Main]: Key plugin ID: "qm-keydetector:2"
Debug [Main]: LegacySkinParser loading skin: "C:/Program Files/Mixxx/skins/LateNight"
Debug [Main]: "Error: Unable to import console: no such extension"
Debug [Main]: "Error: Unable to import svg: no such extension"
Debug [Main]: Skin is a >=1.12.0 style skin.
Debug [Main]: Created QGLWidget. Context Valid: true Sharing: true
Debug [Main]: GLWaveformRendererSignalShader::loadShaders
Debug [Main]: WaveformWidgetFactory::setWaveformWidget - waveform widget added in factory, index 0
Debug [Main]: Created QGLWidget. Context Valid: true Sharing: true
Debug [Main]: GLWaveformRendererSignalShader::loadShaders
Debug [Main]: WaveformWidgetFactory::setWaveformWidget - waveform widget added in factory, index 1
Debug [Main]: Created QGLWidget. Context Valid: true Sharing: true
Debug [Main]: GLWaveformRendererSignalShader::loadShaders
Debug [Main]: WaveformWidgetFactory::setWaveformWidget - waveform widget added in factory, index 2
Debug [Main]: Created QGLWidget. Context Valid: true Sharing: true
Debug [Main]: GLWaveformRendererSignalShader::loadShaders
Debug [Main]: WaveformWidgetFactory::setWaveformWidget - waveform widget added in factory, index 3
Debug [Main]: WSearchLineEdit - Background color: QColor(ARGB 1, 1, 1, 1)
Debug [Main]: WSearchLineEdit - Foreground color: QColor(ARGB 1, 0, 0, 0)
Debug [Main]: WTrackTableView::loadTrackModel() HiddenTableModel(0x2c7221998e0)
Debug [Main]: WTrackTableView::loadTrackModel() MissingTableModel(0x2c722199720)
Debug [Main]: WTrackTableView::loadTrackModel() PlaylistTableModel(0x2c723facc60)
Debug [Main]: Recordings folder set to "C:/Program Files/Mixxx"
Debug [Main]: WTrackTableView::loadTrackModel() QSortFilterProxyModel(0x2c718a68bf8)
Debug [BrowseThread]: Append last  0
Debug [Main]: WTrackTableView::loadTrackModel() AnalysisLibraryTableModel(0x2c722199aa0)
Debug [Main]: BaseTrackCache(0x2c71e609820) updateIndexWithQuery took 8 ms
Debug [Main]: AnalysisLibraryTableModel(0x2c722199aa0) select() took 22 ms 1399
Debug [Main]: AnalysisLibraryTableModel(0x2c722199aa0) select() took 12 ms 1399
Debug [Main]: DlgAnalysis(0x2c71dc1a5d0, name="DlgAnalysis") analysisActive false
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: WSpinny(): Created QGLWidget, Context Valid: true Sharing: true
Debug [Main]: Unknown property qpoperty-layoutAlignment
Debug [Main]: Unknown property qpoperty-layoutAlignment
Debug [Main]: MixxxLibraryFeature::activate()
Debug [Main]: WTrackTableView::loadTrackModel() LibraryTableModel(0x2c722198ae0)
Debug [Main]: LibraryTableModel(0x2c722198ae0) select() took 12 ms 1399
Debug [Main]: trying to restore position
Debug [Controller]: ControllerManager: Setting up devices
Debug [Controller]: Scanning PortMIDI devices:
Debug [Controller]:  Found output device # 0 Microsoft MIDI Mapper
Debug [Controller]:  Found output device # 1 Microsoft GS Wavetable Synth
Debug [Controller]: Scanning HSS1394 devices:
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler1]"
Debug [Controller]:    Nodes detected: 0
Debug [Controller]: Scanning HID devices:
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler2]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler3]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler4]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler5]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler6]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler7]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler8]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler9]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler10]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler11]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler12]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler13]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler14]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler15]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler16]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler17]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler18]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler19]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler20]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler21]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler22]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler23]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler24]"
Debug [Main]: BaseTrackPlayerImpl::slotLoadTrack "[Sampler25]"
Debug [Controller]: Found "Logitech" "USB Receiver" "r4625" S/N "" "Interface 2"
Debug [Controller]: Found "Logitech" "USB Receiver" "r4625" S/N "" "Interface 1"
Debug [Controller]: Found "Logitech" "USB Receiver" "r4625" S/N "" "Interface 1"
Debug [Controller]: Found "AsusTek Computer Inc." "AURA LED Controller" "r512" S/N "00000000001A" "Usage Page 255 Usage 1"
Debug [Controller]: Found "Logitech" "USB Receiver" "r4625" S/N "" "Interface 0"
Debug [Controller]: Found "Conexant" "Sennheiser Main Audio" "r16" S/N "00000000" "Interface 5"
Debug [Controller]: Found "Conexant" "Sennheiser Main Audio" "r16" S/N "00000000" "Interface 5"
Debug [Controller]: Found "Conexant" "Sennheiser Main Audio" "r16" S/N "00000000" "Interface 5"
Debug [Controller]: Found "Logitech" "USB Receiver" "r4625" S/N "" "Interface 2"

Hello @daschuer
I think I found the mistake. It seems to be a bug in MIXXX and not a hardware problem.
I am using 2 screens with exactly the same resolution via Displayport.
The next time I start MIXXX, it gets stuck and nothing works anymore.
So if MIXXX is running on the second screen, it no longer works, if I start MIXXX on the primary screen, there are no problems.
But if MIXXX crashes on the 2nd screen, you have to delete the cfg and soundconfig.xml and then restart MIXXX.

Maybe someone can understand that. We also tried it on another computer, there is the problem too.
Greetings Lupo

PS: I have tested it with different versions of MIXXX. The same problem everywhere.

Had you tried 2.3.0 beta?

Can you check if https://github.com/mixxxdj/mixxx/pull/3215 fixes the issue?

I’m Using 2.3.0 and the actually Version crashes too…

@hlzhs How can I install QT 5.14 on Windows 10?

I don’t understand QT …
What can I do?

You don’t need to install Qt 5.14. You can test that pull request by going to the Appveyor builds below the PR and grabbing the MSI build artifact.

Sorry, but I can’t find anything there and don’t understand what you mean :-/

If you don’t have a GitHub account the link is indeed a bit hard to find.

Follow the link to the Pull Request (PR) I posted above, Then scroll down and click the little icon next to the latest commit hash, then click on “Details” next to the Appveyor check:

Then click on the Visual Studio build:

On the right side of the screen, click on “Artifacts”, then download the MSI file from the list:

You should probably back up your Mixxx configuration and library before upgrading. Check the manual for details: https://manual.mixxx.org/2.3/en/chapters/getting_started.html#upgrading-mixxx

1 Like

Okay understand…
And Same Problem. :frowning:

What have I do:

I completely uninstalled the existing version, removed the files from * Appdata … *, then installed the beta (MSI) from Github. At the first start everything reconfigured (sound, headset, mic and library read in again) test run, everything ok. Mixxx was running on the 1st screen. Then Mixxx moved to the 2nd screen. Mixxx was still running. Then Mixxx exited and restarted.
Mixxx started on the 2nd screen and nothing worked …

Okay, thanks for testing. It was worth a try.

Yep, it was worth a try :slight_smile:
I have now solved it differently: I have now set the 2nd screen as the primary screen and run the Mixxx there, my other programs, e.g. I now run Secondlife on the 2nd screen, as it is right in front of me and the 1st screen to the left. That’s how I solved it once and will test your versions again and again until it works.

Where can I get the latest information when new beta versions are released, so I can test them right away?

regards Lupopa

Hello, it’s me again, couldn’t stop experimenting :slight_smile:

I found out something again. In the mixxx.cfg the settings in the [MainWindow] are saved after completion, which look different, maybe this will help you further to troubleshoot.

The first entry is the 1st screen
The second entry is the 2nd screen

mixxx.cfg

Primary Screen:

[MainWindow]
geometry AdnQywADAAAAAABRAAAAWwAABwgAAAPDAAAAUQAAAFsAAAcIAAADwwAAAAAAAAAAB4AAAABRAAAAWwAABwgAAAPD
state AAAA/wAAAAD9AAAAAAAABrgAAANUAAAABAAAAAQAAAAIAAAACPwAAAAA

Second Screen:

[MainWindow]
geometry AdnQywADAAD///jnAAAAKf///6AAAAOx///46AAAAEj///+fAAADsAAAAAEAAAAAB4D///joAAAASP///58AAAOw
state AAAA/wAAAAD9AAAAAAAABrgAAANUAAAABAAAAAQAAAAIAAAACPwAAAAA

If you have closed mixxx via the 2nd screen, Mixxx can no longer be started without a crash … Remedy for restarting is: You edit the mixxx.cfg and delete the entire entry [MainWindow] including the parameters below. Then mixxx starts again in the 1st screen without crashing.

Please open a bug report on Launchpad: https://github.com/mixxxdj/mixxx/wiki/Reporting%20bugs

This might be a Qt bug. Restoring the window geometry from previously serialized data is a built-in function:

Even if it doesn’t work correctly it must not crash! Maybe a Windows-only issue? No issues so far on Linux/GNOME with a multi-monitor setup.

Geez :frowning:
I had to reinstall my Windows 10 Pro due to a hard drive problem.

Now I have a guilty conscience:-)
Mixxx now runs problem-free with the reinstallation of Windows. On both screens.

I hope I have not caused you any sleepless nights and will resolve the issue for now. Should such a problem occur again, I will create a new thread so as not to create confusion.

Thank you very much for your support in troubleshooting.

Regards
Lupopa