Mixxx over Zoom?

Anyone have any experience DJing over Zoom using Mixx? I’d like to be able to route the audio form Mixxx to participants with the option of also turning on my mic to speak to them occasionally. I’m using Windows 10. Any suggestions on how best to accomplish this?

It’s pretty straightforward. Open MIxxx preferences and set audio output to Zoom Media. Within Zoom go to Share Screen (you can share any screen, it doesn’t have to be MIxxx) and also check ‘Share Computer Sound’. Anyone who joins the ‘meeting’ should then be able to hear whatever you’re playing on Mixxx. Mute your mic for playing music, unmute to talk over it. I think that should work.

I’ve tried what you suggest, but I don’t have the option to choose the audio output to Zoom Media. My options are none, HD-Audio generic, HDA ATI HDMI, pulse, hdmi, and default. None of these work. I tried the “Query Devices” button and Zoom Media doesn’t show up (yes, I’ve got a Zoom meeting in progress and I have done the “Share Computer Sound” option.

I’m using Linux (Cinnamon). I was able to get sound to Zoom from my computer using SMPlayer, but that’s not a great option for DJing.

Thanks for your time.

1 Like

shandypockets, are you still following this thread?

bormikstel5, did you find a way to do what you wanted?

Hey, sorry, been pretty busy…that’s really the limits of my knowledge, but good luck finding more info, sorry I can’t help more.

I got it to work. Mac Big Sur, Mixxx 2.2…

Mixxx prefs> set headphone output to ZoomAudioDevice , ch 1 & 2

In Zoom … share screen>Advanced tab>Computer Audio (choose mono or stereo from little hidden window)

This got Mixxx playing through Zoom while sharing, with my computer mic in Zoom being the one to mute and unmute for talkovers. Unmuted zoom participants could still talk over, so you might want to control the zoom meeting a bit…

Hope this helps.

(I did install BlackHole as a virtual patch bay, but am not using it. It MAY help bring up the Zoom option in Mixxx)

Mixxx is better in every aspect and detail

Hello all
I found a good way to use Mixxx with Zoom on Linux which I wanted to share here
.
As Mixxx uses ALSA sound system, you need to change a hidden setting in Zoom to make it use ALSA as well :

edit ~/.config/zoomus.conf

replace system.audio.type=default by system.audio.type=alsa

So, Mixxx and Zoom will now use the same audio system.

Then, setup kind of a ‘virtual audio cable’ by installing ALSA audio loopback module : sudo modprobe snd-aloop

Now, you can set Mixxx main output to ‘Audio loopback’, and select the same ‘audio loopback’ as a “microphone” in Zoom. You now have Mixxx output going live to your Zoom meeting !

I had best results with echo cancellation set as minimum, and rate as 48Khz.

Also, I directed Mixxx “headphone output” to my headphone for monitoring and preview, and my computer microphone as Mixxx “Microphone 1” for talkover.

1 Like