Multi-channel card headphone monitor instructions on Windows

Hi I posted before about this issue and have sorted it now. Here’s how I did it.
I think this will only work with this type of sounc card. If you’ve not got a 5.1 or above I think you need an external soundcard. Theres lots of posts about this elsewhere.

I’m running Windows 7 64 bit
Realtek HD 7.1 soundcard
2.1 speakers with subwoofer (1 output from machine)

Here goes:
Plug your speakers into the lime green output on your soundcard
Take your headphones out the yellow/gold output

Download ASIO4ALL (Google it, it’s the first result)
Open Mixxx
Open ASIO4ALL (little green icon on task tray when MIXXX is running)
Go to ASIO4ALL advanced (spanner icon)
Expand your chosen soundcard (I’ve only got one) and highlight all the inputs / outputs by clicking the power symbol on the left
Close ASIO
Go to MIXXX options / preferences
Set Sound API to ASIO
Set Master to ASIO4ALL v2 channel 1-2
Set Headphones to ASIO4ALL v2 channel 3-4
Apply
OK

Run 2 tracks hit the headphone button on one and hey presto your done!

Hope this helps.

These instructions should work with any multi-channel sound card, internal or external, though the channel numbers may be different depending on which you enable (the power symbol in ASIO4ALL.) Thanks for the writeup!

Hello!
A headphone monitoring doesn’t want work with E-mu 0204 USB (it has 2 independent stereo outputs).
The ASIO 2.10 driver is installed and works correctly. I did everything according to instructions but I hear master on headphone :frowning:
What can I do to make it work properly?
Thanks.

Can you please post screenshots of your setup?

I’m running onboard Realtek 7.1 sound from my desk top and what I’ve done is go to the Sound Manager in the task bar, went to Device Advanced Settings and set ‘Playback device’ to ‘make front and rear output devices playback two audio streams simultaneously’ and then into prefs in Mixx and set Master to ‘Speakers (Realtek HD Audio)’ to channels 1 and 2, and headphones to ‘Realtek 2nd output’ also to channels 1 and 2. It’s a bit cumbersome, and I seem to have to reset it every time I start Mixx, but it works fine. It’ll do for the time being. I haven’t seen this mentioned anywhere so it’s either been overlooked or has a major flaw!

Man, I’m looking forward to this. I haven’t DJ’ed at all in nearly a decade and this seems a lot easier than digging out my old 1200s. All I need now are a decent set of phones. :smiling_imp:

I think I found a way of monitoring even with a single output soundcard (I have a Realtek HD Audio on my notebook).
It’s a bit complex but seems doing the job.
I’ve done it in Windows, but I believe the same results are achievable in Linux and maybe even in OSX.

I downloaded and installed ASIO4ALL (http://www.asio4all.com) and Jack (http://jackaudio.org/) and configured Jack as described here: http://jackaudio.org/jack_on_windows.
Then I started Jack Server (Jack PortAudio), Jack Control and Mixxx.
In Mixxx “Options” -> “Preferences” I choose “Sound API: ASIO” and matched sample rate and latency to Jack Control “Setup…” configuration.
Then I choose for Master “JackRouter - Channels 1-2” and Headphones “JackRouter - Channels 3-4”.
I went to Jack Control and open the “Connect” window. Here I connected Mixxx “out1” and “out2” to System “playback1” and “out3” and “out4” to “playback2”.
Now I hear Master Out on the left channel and Headphones Out on the right channel :wink:

Hope it’s useful :slight_smile:
(I’m new here so I hope I haven’t done anything wrong ^^")

well done!

i always knew you could do this in linux but i thought windows users were out of luck.

how the latency?

It depends on the settings, but for me was very low (unnoticeable) :wink:

Gday,

I am brand new to this and a little uneducated.
I have a single output sound card in my laptop which has one 3.5mm audio jack.
I’ve downloaded Mixxx and now need to split it’s output between speakers and headphones. I was looking at getting a USB sound card.
I figure this will work as long as I can split one of Mixxx’s channels to the USB. Am I on the right track?

agos, I don’t understand how you split the audio to two devices (headphones/speakers)

Cheers,

Sack

Also, what kind of driver/s set up would I need for the USB sound card?

The USB soundcard I just got (Behringer UCA222, very good for the money, under £20 from amazon) comes with an ASIO driver but you should not install them - just let Windows install standard USB audio drivers.

If you then download and install the free ASIO4ALL (as described above) you can configure it to manage both your internal soundcard and the USB card; if you then choose “ASIO” as the sound API in Mixxx configuration they will appear as “ASIO4ALL - Channels 1 & 2”, “ASIO4ALL - Channels 2 & 3” and “ASIO4ALL - Channels 3 & 4”; channels 1&2 will be the internal card and 3&4 will be the USB card. I’m using the internal card for the headphones because the behringer has line-level outputs and sounds much better.

To reiterate, when I use the behringer drivers and drive it through ASIO4ALL it runs about 1/4s behind, so just dump them and use the standard Windows drivers. I have it configured with 1.45ms latency in mixxx and 64-sample buffer size in ASIO4ALL and it just works.

I still get the occasional bit of audio glitching, I’m not sure why - it’s not CPU (it’s running around 30%) and I can’t imagine that it’s USB bandwidth; I’ll keep playing - knowing the way I am it’ll turn out to be one of those things that I enjoy making it work more than I actually enjoy using it… :slight_smile:

Thank you! :slight_smile: I was using a little trick with the realtek drivers to get the same results, but it was not an “universal” solution, and with jack we add low latency and the possibilty to use VST plugins and what not…

The only comment is that, for me at least, it’s better to map out1 and out3 to playback1 (L-L to L) and out2/4 to playback2 (R-R to R)

From my own experience (and what i’ve read elsewhere), two different devices for output (instead of two outputs of the same device) it’s a no-no… different clock signals makes difficult to make it sound right/in synch. So use only the internal or only the behringer, but not both at the same time (if you want it to sound right :slight_smile:)

This might sound dumb, but I had same problem. I realized I was being stupid and forgot to turn Pre/Main all the way to the left to head the preview but cut out the mian from headphones. Hope this helps also :slight_smile:

Great instructions! Thank you. However, although I followed them to the letter, Mixxx still will not show me an option for Channel 3-4, through which I need to run either my cue headphones or main speakers.

I want to us my Beringher 202 USB Soundcard for the main speakers, and the internal (Soundmax) soundcard on my Windows laptop for headphone cueing, but no matter what I do, no Channel 3-4 option shows up to select. Can someone please help me with this?

Thanks.

I did the same thing, but I still hear the main output and headphone outputs both playing simultaneously through the main speakers and the headphones when I try to cue a song. If I slide the fader all way to the left, deck 1 output plays through both. If I slide the fader all the way to the right, deck 2 output plays through both. The middle position plays both songs at once. The headphone icon buttons don’t help isolate the two signals at all.

What do I need to do to get this working?

I just wanted to put this out there because I struggled with it for a couple of hours before finally figuring out how to make it work and I wanted to post it for anyone else having the same problem.

Windows 7 64bit
Focusrite Saffire 6 USB

Don’t install ASIO4ALL (it didn’t work for me)
Under Preferences > Sound Hardware, set Sound API to Windows WDM-KS
Set Master output to Saffire 6 USB > Channels 1-2
Set Headphone output to Saffire 6 USB > Channels 3-4
Make sure the O/P 3-4 button next to your headphone jack on the Saffire is engaged
Now the 1/4 inch outputs on the back of the Saffire are your master outputs and your headphone jack is your cue
DONE

I tried using ASIO (Focusrite ASIO AND ASIO4ALL) with no luck, and Windows DirectSound would not split the output signal (outputs 1-2 and 3-4 were the same). It took me a while to figure out that Windows WDM-KS was the only way to make it work. Hope this helps anyone having the same issue!

I have skype installed on my windows PC. Skype installs an extra audio driver “communication headphones”.
In Mixxx, I use the following sound map in MME:

  • main audio on “Speakers/HP”
  • headphones audio on the “Communication Headphones”

This setup is okay for practice but not for a real gig ofc…

If im using a laptop and do not have the green port for speakers, what would be the best thing to use? Are there usb cords that can plug into speakers?

Important to know: the onboard-interface has to run in a non-stereo mode (4.1, 5.1 or higher). If not, you can’t select all the single channels via the ASIO4ALL driver and you only see a stereo-pair, like using DX, MME or something. You can set the mode in the software which came with the crappy onboard shit. :smiley:

Laptops only have one stereo jack for speakers or headphone, so you only can listen to the master or cue channel. Except if you use the left channel as the master and the right as cue…

Buy a cheap usb-interface with four outputs at minimum.

I have an ESI U46SE. Runs great with Linux. :slight_smile: