Raspberry Pi 4 OpenGL Waveform

Hi, I tried to use the RGB (GLSL) type of waveform, but I get the error
QGLShader::compile(Fragment): 0:1(10): error: GLSL 1.20 is not supported. Supported versions are: 1.00 ES, 3.00 ES, and 3.10 ES
So I tried to override the GL version using MESA_GL_VERSION_OVERRIDE enviroment variable but without success.
The output of the command sudo glxinfo | grep "OpenGL" is

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 9.0.1, 128 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 19.3.2
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.1 Mesa 19.3.2
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 19.3.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:

The kernel version is: 5.4.72-v7l+

Thank you for any help

I have a very similar problem with odroid xu4 (similar device) – never got openGL to work on any Mixxx 2.1.8 up to 2.3 on ubuntu mate 18.04 or 20.04. This might be a graphic driver kernel issue, more than a mixx issue, but not sure…
The machine is fast enough for software rendering on waveforms, but I really miss the spinny display of the turning disk symbol…

Looks like your hardware doesn’t support GLSL 1.20 just as the error message says. You could try MESA_GLSL_OVERRIDE (not MESA_GL_OVRRRIDE) but no idea if that will work.

OpenGL waveforms seem to work on 64 bit raspbian.

Have you ever tried it?

I have a working image of it based on raspbian right here :slight_smile: