Route master output through headphones/auxiliary

Hi,

I’m doing some very basic mixing at a radio station. I play music from my macbook via an audiojack that plugs into the headhpone socket. (In other words, the radio broadcast comes from my laptop through the headphone socket).

Some time ago I had mixxx configured so that I was able to play the master output directly out through the auxiliary (headphone) output. I did some basic previewing and cueing of the subsequent track by playing the audio through the inbuilt speakers, which is pretty crude, but it worked and I was happy enough.

But now I’m not able to figure out how I did this. When I open up Mixxx preferences to try to send the master output through the headphones, Mixxx just does not allow me to do so. There is no option in the dropdown list corresponding to “headphones”. The closest is “Macbook pro speakers”, which I want to use to cue.

Please help or feel free to suggest alternative approaches.