Shoutcast Error

I’m searching the forums for a solution but can’t find it.
Basically I have a server running both Shoutcast 1 & 2. Mixxx isn’t working with either and I have no problems connecting with the Winamp DSP on both versions 1 or 2. Whats the deal?
and if your supporting v2 why isn’t it listed in the drop down?

Did you read the respective manual section ?

Hello JVonD.

I also have some problems to connect to streaming servers. As it’s indicated in the version history (thanks to ronso and hlzhs), the way to solve this bug was to upgrade Mixxx to the latest version.
Can you tell a bit more about what isn’t working, your OS and your Mixxx version ?

For reference: Error when connecting to a streaming server

Thanks guys! I appreciate the help.
I just reviewed the link above to the setup.
I’ve tried every combination of entries while trouble shooting. Wonder if it has anything to do with the new shoutcast server.
I have tried both 2.2.4 and the new beta 2.3 and both can’t connect. I can’t even get a response from Shoutcast 2. Shoutcast 1 keeps telling me my password is in the wrong format.

I used the same settings as my winamp DSP with or without the “/”, longin, stream name entries… Can’t figure it out. With the Winamp DSP it’s a piece of cake, works everytime. I’ve been hosting my own server for over 10 years so I’m definitely not a newbie to shoutcast.
Mixxx seems pretty cool. Hope to put it through it’s paces. Thanks again.
Have a good day! ~J

I think I remember to have read somewhere that, a solution could be

  • to connect with user:password with the sign «:» between user and password, in the user area (and password is left blank) or in the password area (and user is left blank)
  • to set a name for the stream in the stream info (with «public stream» ticked)

I don’t understand why this solution would work but, it worth a try…

Dude you are the man! It worked. Thanks a bunch!
Here’s the minimal setup for Shoutcast1.
Host- URL
Port- PORT#
Login- BLANK
Mount- BLANK

Good. Glad it helped you :slight_smile: