Talk and Ducking not working


I have Mixxx and have been using it for two months. Last week the Talk Button and Ducking button worked, this week they do not. The microphone works and records without having to touch the talk button and the ducking does nothing.

Can anyone help

please share a screenshot of the mic section.

are you maybe using a controller mapping?
did you change anything in the Preferences?

We’re sorry, but your email message to [“”] (titled Re: [Mixxx] [Help & Support] Talk and Ducking not working) didn’t work.

from the screenshot it is not clear how the mic could be routed to the main output (and recording).
it ould be that the control [Microphone],master is set to 1, but that control is not reachable from the regular GUI.

are you sure your sound devices are still set up correctly in Preferences > Sound Hardware? Please post a screnshot of that page.

hmkay, nothing suspicious, and if you say you didn’t change anything in between “last week” and now (actually you didn’t answer that question)… I guess it’s some control under the hood which is messed up.

When the Talk button is not pressed, the only way to hear Mic1 in the main mix is --IIRC-- if [Microphone],master is set to 1. Via GUI this is not possible with the officia skins, also it’s (should) be reset to 0 every time Mixxx starts. And it can only be toggled by a controller mapping or some custom skin (or some custom keyboard mapping).

If you like to find out if that’s he case you need to

  • start Mixxx in developer mode
    16. Appendix — Mixxx User Manual

  • open Developer menu, Developer Tools action, Controls tab.

  • paste [Microphone],master into the search field at the top (this is for Mic1, for other mics use [Microphone2] etc.).

  • check the value in the the third column

Hi Ronso

I have managed to locate what had happened and I have resolved it, you advice helped although I did not or could not do the open developer

To help others who may encounter the same issue:
what was the cause? how did you fix it?

1 Like