The minimum size of the selected skin is bigger than your screen resolution

Hi, I switched from a 15’ laptop to a new 14’ ThinkPad laptop resolution 1920 X1080 and now I can’t get Mixxx to fit my screen. In ‘preferences’->‘interphase’ I get a message: “the minimum size of the selected skin is bigger than your screen resolution” . I’ve tried changing my computer’s resolution, changing the scheme of Mixxx looked for answers on the web… and so far nothing has worked… It will be impossible to work like that… I don’t know what to do… Maybe the resolution of my new pc is too good… Is there any solution? Thanks for reading!

The Mixxx skin demanding the most screen space is LateNight (as of Mixxx 2.3), it needs 1280*668 px.
So it looks like you have some OS screen scaling activated, probably 150% which turns you FHD screen into a 1280*720 screen, but even there even LateNight should fit.

change it back to 1920px and look for app scaling in your OS preferences. Either set that to some value >150% for Mixxx or follow this guide

Thank you for your reply! I use ‘shade’ ‘classic’ with 1920pix and 150% scaling. I’ve tried 175% and it’s a little better but the 175% affects everything not only mixxx. I’ve tried the commands in the cmd window but it didn’t work either. C:\Program Files\Mixxx set QT_SCREEN_SCALE_FACTORS=200% {whatever number I put here didn’t make a difference}

Hmm…for Windows you may need to issue both
set QT_AUTO_SCREEN_SCALE_FACTOR=0 and
set QT_SCREEN_SCALE_FACTORS=your-scale-factor
As stated on the wiki “your-scale-factor” has to be a floating point value like 1.5 (150%)

I just added more details to Troubleshooting · mixxxdj/mixxx Wiki · GitHub

Thanks Ronso, the cmd commands do not make a difference… thanks though for trying.

okay. the try just QT_SCALE_FACTOR=1.5

set QT_AUTO_SCREEN_SCALE_FACTOR=0
set QT_SCALE_FACTOR=1.5
C:\Program Files\Mixxx\Mixxx.exe

Btw you can ignore “the minimum size of the selected skin is bigger than your screen resolution” and just hit Apply :wink:
And post a screenshot of the result (Mixxx in fullscreen mode, F11) so we can see what exactly is wrong.

Thanks for being with me on that!

considering Shade needs 1008px in width and it is cut off there, you must be running Mixxx with actual 200% scaling.

That is either coming from Windows itself (please double-check:

  • apply the 125% or 150% you need for 14" FHD display
  • restart to be sure, after all it’s Windows :wink:

or
there is Qt scaling added on top of your >100% Windows app scaling.
please double-check: run the following commands in the same cmd terminal window

  • disable automatic scaling set QT_AUTO_SCREEN_SCALE_FACTOR=0
  • then reset Qt scaling to 100% set QT_SCALE_FACTOR=1.0 and
  • to be sure set QT_SCREEN_SCALE_FACTORS=1.0 (which should actually override the former factor)
  • run Mixxx C:\Program Files\Mixxx\Mixxx.exe and post another screen shot

Hi, when I change the resolution from the default 150% to 125% using windows’ control-panel settings, indeed Mixxx fits into the screen but the text in Mixxx becomes tiny. Strangely, it’s enough that I change the resolution to 149% using windows settings for Mixxx to fit but then Mixxx’s top panel becomes very small. I added a screen shot with windows interphase for a text-size comparison.

With 150% windows scaling 1920 becomes 1280 and all Mixxx skins should fit the screen in fullscreen mode without anything cut off (even if the warning in the Preferences pops up).

Each Mixxx skin is designed for a different use case, thus the font sizes vary. Shade is meant to fit small screens (1024px) and the fonts in the decks (“Mixxx’s top panel”) are accordingly small.
You can try other skins, fonts are mostly taller there.

Note that you can adjust the font type and size of the library independently in Preferences > Library

1 Like

Thank you! Problem is solved!!
Is it possible to increase the size of the deck?

So, just to make it sure,
you now have a batch file to start MIXXX with the following text:
set QT_AUTO_SCREEN_SCALE_FACTOR=0`
set QT_SCALE_FACTOR=1.0
set QT_SCREEN_SCALE_FACTORS=1.0
and you are very close to what you want to have, great !
Now you can test different values for the last value, eg.
1.2 1.3 1.4 …
für my system 1.4 works perfect.
In the next stept you can test different font sizes for the library in → settings → library, for me 10pt is very good.
With these factors you will find a setting that fits perfect to your system.

1 Like

All controls and all fonts are fixed in size (except the library). Decks and most other regions are fixed in height and stretch horizontally to fill available screen space.

If the fonts are too small for you you can only scale the entire Mixxx app as @abseits explained in detail and try to find a scale factor that suits your needs.