This is a mixx keyboard for mixing without a controller or mouse :)

You just need to replace the file
Custom.kbd.cfg
in the mixxx configuration folder.

I use mixxx without a controller, using the keyboard mappings*, but flying without a mouse? You’re brave! :smiley:

(* I did add an extra keyboard shortcut for centring the crossfader with a single key, though. :slight_smile: )

figuring out the mapping from the cfg alone is bit tedious. Some kind of overview is required IMO, like an keyboard image, or simply a table.

Then it would also be easier to see what makes this mapping special. What was your goal?

1 This is how I used mixxx at the beginning without a controller and no mouse,
just by using the hotkey control.
I’m not brave, I just had no other choice.
If you want, I can send samples of the recorded sets this way.
2. Where did you find a free single key to center the crossfader with a single key?
all the singles were already taken and now you are doing two functions at once
with this key.
two shortcuts were used to center the crossfader,
Shift + B & Shift + N both did the same.
Best regards.

I understand it’s hard to see everything in a cfg file.
Therefore, I will try to make a description in the table.
Keyboard photos won’t be because there are too many shortcuts and there would be several photos for several layers of shortcuts.
My goal was to create a very extensive keyboard for mixxx,
so that this program can be used by people who operate computers only with the keyboard, for example the blind.
They can’t use a mouse and at first not everyone wants to buy a controller to try the art of mixing.
However, they do very well with many keyboard shortcuts.
Best regards.

1 Like

I meant that I did that on my keymapping, not on yours.

1 Like

Hey dear gentlemen.
Who can help me?
what should i use to hear microphones
on the master channel.
when talkover is on?
Now I can hear both voices on the preview channel when PFL is on.
On the master channel I can hear both only when master is on, but talkover is off.
I would like to hear microphone 2 when it says something, when talkover is on?
Now I only hear the auto ducking of the master channel.

[Microphone]
talkover Space
master Ctrl+Shift+Y
pfl Ctrl+Shift+Y
volume_down Shift+{
volume_up Shift+}
volume_set_default Shift+|

[Microphone2]
talkover Ctrl+Space
master Ctrl+Shift+T
pfl Ctrl+Shift+T
volume_down Ctrl+[
volume_up Ctrl+]
volume_set_default Ctrl+\

Don’t mess with master and talkover at the same time.
The manual clearly states:

For [MicrophoneN] use [MicrophoneN],talkover instead.

talkover respects the ducking mode and button = lowers the music according to the Ducking Strength knob. Center the knob and try again.

master will always route it to master, regardless of the ducking settings. Plus you have no GUI feedback in official skins.

1 Like

Forgive me,
I understand my mistake with using a master for the microphone.
Unfortunately, I will never be able to see the GUI in the official skins.
But a man checked the mike section for me and what I’m looking for isn’t there.
Maybe I should look for it outside of the mike section.
I will try to describe my problem again.
I’m using a switch
headMix_minus_toggle
or the handset / master balance knob
to the 100% position of the master channel.
When I hear the master channel on my headphones and use the talkover switch
the music goes down but I can’t hear the microphone 2 sound.
Microphone 2 sound is recorded and broadcast online correctly,
only I can’t hear him in my headphones.
I can only hear it when I use the PFL switch
and the master / headphone balance knob is in the headphone position.
I don’t know if it’s achievable to hear the inputs of the other microphones except mine in the 100% master balance knob position.
It remains for me to use the Auxiliary input to connect this microphone.
Thank you for your patience :slight_smile:

Okay, now I got it.
I think what you want is covered by a preferences option.
Go to Options menu > Preferences > Sound Hardware > Microphone Monitor Mode
This is covered in the manual in using mcrophones

In short

  • software monitoring: should do what you want (hear all mics in the main output) but has a delay which may be confusing (for your own mic)
  • direct monitoring: sends the mic to Rec and broadcast only

Regarding you request to route only selected mics(s) to the main output (in software monitor mode):
that is totally reasonable. I’ll file a reprt on the bug tracker https://bugs.launchpad.net/mixxx/

1 Like

We are just starting our adventure with DJ and support for such an advanced program as Mixxx, so I apologize if I will talk about something unprofessionally in the future.
Thank you very much for reporting the problem and for your explanations.

1 Like

I’ve added some new shortcuts
and I attach a table with a description of all keyboard shortcuts.
keyboard shortcuts for Mixxx.7z (88.7 KB)