Tonor USB Microphone w/o built-in headphone jack

I’m am helping a friend try and live stream a radio show. I am a mac guy and use Audio Hijack flawlessly. I thought Mixxx would be a great solution but when I push the Talk button I get a message to set-up in the source. Input preferences for the mic shows the Tonor (no headphone jack on mic) and I select it but shows only 1 Channel as the option not 1 and 2 channel. When I apply and leave preferences it’s like a vicious cycle of non-recognition. I’ve tried restarting the system and other options. Seems like others are using USB mics but the manual suggests not using USB mics. I’m so confused and would appreciate any assistance in making this work. It shouldn’t be this hard!!