Touchscreen on raspberry with mixxx > 2.1.8

I’m using a raspberry and i have different touchscreens.
With mixxx versions < 2.1.8 (QT4) i had no problem at all.
Starting with mixxx 2.2 (QT5) all my thouscreens that act like touch devices stopped working.
The touchscreens that emulate a normal mouse still works, (in this kind of touchscreens if you drag over a web page the text will be selected as if you click and drag a real mouse).
The touchscreens that act as a touch devices are the one that, if in a web page you drag over the page, the page scroll, so a different behaviour with respect to a normal click-and-drag action done with a mouse.
Switching to mixxx > 2.1.8 had broke this compatibility, now all the touchscreens that raspbian handle like “touch devices” and not like “normal mouse” doesn’t work anymore.
How can i use the latest version of mixxx on this kind of devices?

1 Like

Does it work with the latest 2.3 beta? This should be fixed as of a few weeks ago. https://github.com/mixxxdj/mixxx/pull/3021

Not sure how you’d get Mixxx 2.3 beta on the rpi - I couldn’t manage to build it on it even.

Yes, tons of compilation errors when trying to compile 2.3 beta on rpi.
Although, i took a look at the code change in that pull request… i don’t think that’s the point, in this case even the top bar (the one with “file”, “options”, “view”…) is not responding to touchscreen.

About the menu bar: it might be a problem of fullscreen+QGLwidgets +QT 5.12+.
Try either running it windowed or with --safeMode so that opengl is not activated on the whole screen.

No neither with --safeMode the touchscreen works (even in the menu bar).
Workaround: do you know touchegg? is an application used for mapping touchscreen gestures… i have mapped single touch to mouse click and guess what? is working!
Basically i’m changing touch events to mouse click events.
The problem however remains because the elements of the UI in which the touch was working (loop buttons, tempo buttons…) now receive 2 inputs and they don’t work enymore (toucheggs is not preventing the default touch event to be thrown).

I can confirm this issue. I’ve also tried about anything and have the same result on an Odroid XU4 running first Ubuntu 18 and now 20 with Mate desktop.
any version bigger than 2.1.8. doesn’t allow to touch the library. the whole field lights up but the rows are not selectable. Some buttons work, but it’s a bit random.

here an old thread on this https://www.mixxx.org/forums/viewtopic.php?f=3&t=12798

2.3 beta has the same problem. My workaround is a midi device and a mouse, but it’s not as portable as the touchscreen.

The bug with touch input on the library has still not been fixed. If anyone could fix that, that would be much appreciated!

1 Like

Cross posting from launchpad report:

After changing my RP4 screen to a Waveshare DSI touch screen I also found that:

  • Menus could not be clicked
  • Library tree and table items could not be clicked
  • Any skin buttons could be clicked fine

Some debugging later I found that (counter intuitively) commenting out the following line:

https://github.com/mixxxdj/mixxx/blob/c90e38b21131ad48f598c3fd14f8cbbf27860340/src/mixxx.cpp#L219

Fixed the issue and now the touchscreen works as expected. Are you in a position to compile Mixxx from source on your pi and confirm if this fixes the issue?

1 Like

Removing the line that enables touch event support fixes Touchscreen support? Weird.

I’ve compiled release 2.2.4 without setAttribute(Qt::WA_AcceptTouchEvents);
IS FINALLY WORKING!!!

Thank you for confirming this fixes the issue. Development discussion on how to permanently fix the issue is continued in Zulip.

Thank you so much for the fix!!! I could also successfully rebuild Mixxx 2.3beta on Odroid XU4 under Ubuntu 20.04; and now the touchscreen is working!!! :smiley:

(funny/sad note: I made a short-circuit connection on my display shortly after and am in repair mode now)