Unable to connect Mix Rider to Mixxx

Hi everybody

I am trying to use the Mix Rider controller on Android in Mixxx. However, I only achieved it once to get Mix Rider detected and working, and I don’t know how.

I have followed the instructions on the Mix Rider website (https://mixrider.com), so I have installed Mix Rider on my android phone (Xiaomi Mi 9 Lite, running android 10 QKQ.190828.002); I have placed the mapping and script files in the User Controller Mapping Folder, and I have connected my phone to my computer as a MIDI input. But nothing happens when I press the controls in Mix Rider.
I have checked the MIDI output coming out of my phone with MIDI-OX and no output is detected (I have tried with another MIDI keyboard app and an output was detected). I restarted the app multiple times, and it worked only once : a midi output was detected, and I could use the app to scratch in Mixxx. But as I restarted the app and Mixxx, it did not work anymore. I have restarted the app several times again, but no MIDI output is detected.
What should I do, in order to get the app working ?

Thank you, I wish you a good day

(P.S : sorry for my bad english, I’m french)

can you post a screenshot of the controller’s config page?
maybe -for some reason- it’s just disabled after start, or the mapping is not selected anymore?

Here is the config of the device in Mixxx

This is the home page of the app, it has to be started using the start button.

Here is a page of the app once started. Unfortunately, there does not seem to be a settings page.

(sorry I can only post an image at once)

okay, with all the info you supplied and stating that another MIDI app IS sending output it is an issue with the app and/or your phone setup.
Mix Rider is not connected in any way to Mixxx and I never heard of that app before, so you better seek support in the Mix Rider forums?

The problem is that this is a small app, so there are no Mix Rider forums (therefore I asked here). I don’t know any other app to scratch in Mixxx with my phone, so I don’t know what I should do.

I don’t know either, and I’m not familiar with debugging on Android.
In such cases my Usual routine on windows was

  • uninstall
  • reboot
  • reinstall
  • configure again
  • make sure you don’t miss any unconspicous popups
1 Like

Maybe ping @spinims? He or she is the creator of Mix Rider: Mix Rider (controller app for Android)

2 Likes

Hi @dinogame Mix Rider dev here. Thanks for trying out the app! It certainly is a puzzle that it worked and then stopped.

It sounds like you got the setup correct but for some reason MIDI signals aren’t making from the phone to PC anymore. From the screenshot it looks like MIDI subsystem is being detected by app, and if it’s not crashing it’s hard for me to solve remotely.

Good suggestions are already on the thread. EDIT: noted that another USB based MIDI app is working. I will see if I can reproduce the problem and let you know once I think I have a fix.

You are right about this is a small side project, so I can’t promise much in the way of updates. A settings page is next up in the backlog!

Thank you for your answer ! I don’t know myself in development, but I think the problem is linked to the MIDI output on my phone, and I think that Mix Rider doesn’t find / connect to my phone MIDI output.

Besides this bug, your app is amazing and I had a lot of fun as it worked. Keep up the good work !

1 Like