Unable to detect sound when connecting with realvnc on raspberry pi

I am attempting to run mixxx 2.2.0 on a realvnc virtual desktop running DietPi in order to stream to an icecast server, but since mixxx does not detect any sound devices my stream has 0 sound output. Any ideas for how to create or detect a device?

sudo modprobe snd-aloop

does not cause any devices to appear.

If things haven’t changed in the last decade, VNC does not export sound from the target machine into the client machine. eSound or pulseaudio were needed to be configured in addition to that. (And neither of those have network-audio latency good enough for using Mixxx)

Also, I don’t fully understand your setup. The DietPi is where Mixxx is running?
The icecast streaming will be done from the machine that runs Mixxx, but you will need some audio hardware in order to use Mixxx. Either the internal soundcard, or an USB card or controller on the machine that runs Mixxx.

Okay, so to clear things up:

  • The dietpi is running mixxx and streaming to an icecast server
  • I do not care if I hear sound from the vnc connection, but I need to use the pi’s onboard sound device to send sound to the icecast server
  • the problem is that in the settings for mixxx, 0 devices show up as available. I believe that this has something to do with my vnc server session being a virtual desktop (vncserver-virtual instead of vncserver-X11) and not a real one

Mmm… Yes, that might have something to do.

First thing would be to ensure that audio works when using the Pi directly.
I see that there are options to configure audio. You should verify that it is setup correctly:

Once you get sound when running from the Pi, you should verify how you need to start the vncserver.
Back when I used that, I had the machine automatically logging into an user and opening a session into the desktop. So then when I logged with vncclient, I was accessing that desktop.

I am assuming that the vncserver-virtual does not need an X session and instead emulates it. I don’t think this should affect sound in any way (because you want to talk to ALSA), but I have no idea, because I don’t have experience with that scenario.