Varying speed on playback

Hi,

Just imported my database into a new computer. (Lenovo L14 2nd generation with AMD 5600, 16GB ram)
Everything was recognised, so that’s perfect. But now trying playback the songs come out way slower, sometimes come back to their normal speed. It sounds like something is dragging down the PC, but in the task manager MIXXX is sitting with some 300mb of ram used and 2% CPU power usage.
Here is a video so you can hear/see: Mixxx varying speed on playback - YouTube

Can I provide any log output or change a setting to fix this?

Thanks.

This is indeed strange.
Does the track also sound slower (lower pitch)?
What does the xrun counter at the bottom of Pref > Sound Hardware say?
Does increasing the audio buffer fix this?
What happens if you change the pitch bend engine in Pref > Sound Hardware?

Thank you for your answer.

I found the culprit. The “Sound API” was selected by default as “Windows DirectSound” and that gives the error. Switching to another one removes the lag.

By xrun counter, do you mean this?

Indeed, increasing the audio buffer to 46.4ms also removes the issue.

Switching the pitch-bend engine (to Rubberband) did not resolve the issue.

I guess I’ll look into with Sound API is best.

Thank you for your swift help on the issue! :slight_smile:

Great!
re APIs check 13. Preferences — Mixxx User Manual