[Workaround] Mixxx dosn't start after Manjaro's update 21/05/12

Hi community.
For users of Manjaro, since last update available since 05/12 Mixxx do not start due to new Protobuf version.
A workaround of this issue is to create a sim link to older protobuf in system library like this as root user:

 ln -s /usr/lib/libprotobuf-lite.so.27 /usr/lib/libprotobuf-lite.so.26 

Works fine on many machines under Manjaro.

Remember and note this modification in case of conflict situation to be able to remove this link.

Did you build Mixxx yourself or use mixxx_beta-git/mixxx-git from the AUR? If so, you just need to rebuild/reinstall it.

If you installed it from Manjaro’s official repos, that’s a sign of poor QA on their part.

EDIT: It sounds like a AUR issue. From the documentation:

The AUR is unsupported, so any packages you install are your responsibility to update, not pacman’s. If packages in the official repositories are updated, you will need to rebuild any AUR packages that depend on those libraries.

https://wiki.archlinux.org/title/Arch_User_Repository#Installing_and_upgrading_packages

2 Likes

Thanks for reply.
Sorry again with my English…
First, you 're right , I did compile mixxx_beta-git/mixxx-git from Aur . This repo is " at your own risks" but provided by non official but experimented Arch-Users . Officials [Community] packages available for Manjaro users come from Archlinux Repos (but not aur) so I don’t might it’s " that’s a sign of poor QA on their part".
I did just give an often workaround , that I often saw after updates .
The way of Rollings…
Again Thanks for reply.
I really thanks you for kindly remarks .

Symlinking different library versions is not a good idea and might lead to crashes. You just need to relink by running makepkg -f again, as with all AUR packages that depend on that library.

Thanks. I rebuild mixxx_beta-git and it works . I remove the link too.
Ain’t no risk to create a link in /lib if you are a little experimented. If you have a message such

“libprotobuf-lite.so.26 is still present in filesystem”

while updating, you can use this option:
sudo pacman -Syu --overwrite /usr/lib/libprotobuf-lite.so.26 .
Thanks for your job as developer.

Thanks. Unfortunately it’s not my job, we all work on Mixxx voluntarily in our free time :wink: